Voicemail Directory Problems


I’ve searched high and low for this and can’t find a reason for it. I can’t use the directory from inside VoiceMail to leave a message for someone. I dial into voicemail, enter my password, enter 3 for Advanced Options, 5 to leave a message, and then 2 to use the directory. I enter the first three letters of the last name for the person I want to leave a message and it finds the person. When I hit 1 to select the person I get this error message:

Aug 1 09:27:24 WARNING[8209]: app_directory.c:203 play_mailbox_owner: Can’t find extension ‘101’ in context ‘default’. Did you pass the wrong context to Directory?

All of my voicemail users are in the default context so this baffles me. I’ve checked the new config files to make sure I’m not missing an option (I’ve upgraded a few times and kept my original configs). I’m currently on

To clarify, this doesn’t happen if I use the Directory() application via my dialplan, only if I’m inside VoiceMail and try to use the directory to send someone a message.

Thanks for your help!


Nobody else has tried to send voicemail using the directory from inside their mailbox? Come on! Try it for me so I know I’m not crazy. I’ve got a client that has the same problem with ABE B.1-1. Of course, B.1-1 isn’t even on the ABE website yet so I’m wondering if they should be running it. So far we’re having more trouble with it than it’s worth!


here’s a thought - is it consistenly returning 101 for the user no matter who you select, or does the value change based on the name?

in other words, i’d be interested to see excerpts of your voicemail.conf…

edit - i just tried this on my server, and couldn’t even get option 2 to work…i am just prompted for an extension. is option 2 your directory call?

please post more details, if you would

Here’s my voicemail.conf:

emailbody=Dear ${VM_NAME}:\n\n\tjust wanted to let you know you were just left a ${VM_DUR} long
message (number ${VM_MSGNUM})\nin mailbox ${VM_MAILBOX} from ${VM_CALLERID}, on ${VM_DATE}, so y
ou might\nwant to check it when you get a chance. Thanks!\n\n\t\t\t\t–Asterisk\n
emaildateformat=%A, %B %d, %Y at %r
saycid=yes ; Say the caller id information before the message. If not described,
; or set to no, it will be in the envelope
cidinternalcontexts=default ; Internal Context for Name Playback instead of extension digits when saying caller id.
dialout=internal ; Context to dial out from [option 4 from the advanced menu]
; if not listed, dialing out will not be permitted
sendvoicemail=yes ; Context to Send voicemail from [option 5 from the advanced menu]
; if not listed, sending messages from inside voicemail will not be
; permitted
review=yes ; Allow sender to review/rerecord their message before saving it [OFF by default
operator=yes ; Allow sender to hit 0 before/after/during leaving a voicemail to
; reach an operator [OFF by default]
nextaftercmd=yes ; Skips to the next message after hitting 7 or 9 to delete/save current message.
forcename=yes ; Forces a new user to record their name. A new user is
; determined by the password being the same as
; the mailbox number. The default is “no”.
forcegreetings=yes ; This is the same as forcename, except for recording
; greetings. The default is “no”.
msg_type = yes
read_receipt = yes
future_delivery = yes
personal_group = yes
mailbox_forward = yes

eastern=America/New_York|‘vm-received’ Q ‘digits/at’ IMp

100 => xxxx,Janice Wyant,jwyant@wyantcomputerservices.com
101 => xxxx,Victor Geha,vgeha@wyantcomputerservices.com
102 => xxxx,Tom Wyant,twyant@wyantcomputerservices.com
103 => xxxx,Ron Walter,rwalter@wyantcomputerservices.com
150 => xxxx,General Mailbox,info@wyantcomputerservices.com,hidefromdir=yes|delete=yes

To answer your question about 101, I just tried it for extension 103 and got the same error but with the extension number I chose:

Aug 1 15:43:20 WARNING[9721]: app_directory.c:203 play_mailbox_owner: Can’t find extension ‘103’ in context ‘default’. Did you pass the wrong context to Directory?

For option 2 to work you have to have usedirectory=yes in your voicemail.conf.

Let me know if you want more info.



I just tried leaving a message without using the directory and it worked fine.

Dialed into my voicemail, chose 3 (Advanced) and then 5 (leave a message) and then 1 to pick the extension. Entered 101 and recorded my message. Then chose 1 to approve of the message. Worked fine.


hmmm, never had seen anything on that particular flag - it’s not documented anywhere that i’ve seen…

i just enabled it on our system, and when i attempt to find a user in the directory (following the same steps as you) i keep getting a message that no directory entries match, even though i should be matching up on about 5 different users…

my apologies for asking you a question, but any ideas if i’m missing something? i’d like to be able to try and replicate your problem on my system, but i can’t get the damn directory to work.

i’ll keep playing, see what i can come up with…

whoiswes: Post your voicemail.conf and I’ll compare with mine. What version of Asterisk are you on?

Thanks for your help!



Asterisk 1.2.4, also have a few and a BizEd 1.1 box I can play with.

Here you go, I’ve blanked any sensitive info:


emailsubject=New VM (${VM_MSGNUM}) - ${VM_DUR} long in mailbox ${VM_MAILBOX} from ${VM_CALLERID}
mailcmd=/usr/sbin/sendmail -t

294 => *****,Wes ,wes@,attach=yes|delete=yes[/code]

Throw this into your [general] section:


From what I understand, between cidinternalcontexts and usedirectory you should be able to hit 2 and successfully pick a name from the directory. Then again, you’re using [snip] as your voicemail context so it makes me think there’s a problem internally that needs to be addressed.


[snip] is just me snipping out a bunch of the other accounts, it’s not actually a context.

will add that flag and let you know.


nope, no go - added cidinternalcontexts=default and i’m still getting the same message about no entries matching…

Strange. I’ve emailed Digium to see what they have to say since ABE B.1-1 is based on 1.2 and it acts the same as my install.

Thanks for your help!


yeah, very odd, especially since i can’t even get the directory stuff working.

i’ll post back if i discover anything…good luck!