Voice stream works but video stream doesnt work

I have installed asterisk1.8.17.0 into my VPS server.
I can use voice stream but,video stream doesn’t work on Linphone,X-lite. Mac OS and iPad

I have set sip.conf as below.

[default]
videosupport=yes

and each user setting…

[user1]
disallow=all
allow=g722
allow=ulaw
allow=h264
allow=h263
allow=h263p

[user2]
disallow=all
allow=g722
allow=ulaw
allow=h264
allow=h263
allow=h263p

I have installed brekeke sip server for test.
However,result is the same.
So I thought it was because of network and I researched.

a)
iptables -L shows nothing.

Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

b)
I accessed directly to IP address
49.212..*

Do you have any ideas ? please help me.

These are console logs for connection.
It looks that there is no mentions to video.
What message should appear for video connection?

Verbosity is at least 3
== Using SIP RTP CoS mark 5
– Executing [user2@default:1] Dial(“SIP/user1-00000002”, “SIP/user2,30,r”) in new stack
== Using SIP RTP CoS mark 5
– Called SIP/user2
– SIP/user2-00000003 is ringing
– SIP/user2-00000003 answered SIP/user1-00000002
– Locally bridging SIP/user1-00000002 and SIP/user2-00000003
www15000uf*CLI>

I have read around this and think
talk.maemo.org/showthread.php?t=26599

Using only one codec might help.

SO rewrite the sip.conf like this
[user1]
type=friend
defaultuser=user1
secret=user1
canreinvite=no
host=dynamic
dtmfmode=rfc2833
callgroup=1
pickupgroup=1
mailbox=203
disallow=all
allow=ulaw
allow=alaw
;allow=h261
;allow=h263
;allow=h263p
allow=h264

but,showing this message.

[Oct 16 21:57:42] WARNING[31398]: chan_sip.c:9048 process_sdp: Ignoring video media offer because port number is zero

I use X-lite on Mac OSX mountain lion

Hi Herix!

You can try to have “videosupport=yes” in both [general]
and for all the [user*] you want this yo work for!

[code][general]



videosupport=yes

[user1]



videosupport=yes

…[/code]
I tried with this and got both voice and video on a Asterisk 1.4.5
with a Grandstream GXV3000 phone and X-Light with h263 or h264,
but not with both allowed at the same time?
Don’t know why!

Don’t know if this works for Asterisk1.8.17.0!

Hope this might be of a help for you!

Virtually yours // Nypon

Hi nypon
thanks for kindly replying.

I tried videosupport=yes and codecs in both [general] and each users.
but still the same…

Do you have a firewall that might block some ports that is needed?
Do you have NAT and need port forwarding?
If you have a firewall, try to open it up and try again!

HI nypon
thanks again.

My clients are behind the Nat.
So I added the ‘nat=yes’ to sip.conf each user section.

My Server has global adress (VPS)
I have checed iptables and asked data center if there is some firewall between VPS and internet.
There are no firewall.

But video still doesnt work.
and Which port should I open for video?

The port range used by Asterisk will be the same as used for audio. That used by the phone will be determined by the phone.

Rather than stabbing in the dark, you need to enable sip debugging and see exactly what is being negotiated.

Hi david55

I connected to server with asterisk -vvvvvr and checked the log.

   > Saved useragent "Linphone/3.5.2 (eXosip2/3.6.0)" for peer user2

== Using SIP RTP CoS mark 5
– Executing [user2@default:1] Dial(“SIP/user1-00000000”, “SIP/user2,30,r”) in new stack
== Using SIP RTP CoS mark 5
– Called SIP/user2
– SIP/user2-00000001 is ringing
[Oct 20 01:49:03] WARNING[19612]: chan_sip.c:9048 process_sdp: Ignoring video media offer because port number is zero
– SIP/user2-00000001 answered SIP/user1-00000000
– Locally bridging SIP/user1-00000000 and SIP/user2-00000001
– Registered SIP ‘user2’ at 182.***.***.***:4336
– Registered SIP ‘user2’ at 219.***.*.:4108

It is maybe relevant to port number

[Oct 20 01:49:03] WARNING[19612]: chan_sip.c:9048 process_sdp: Ignoring video media offer because port number is zero

I looked up how to slove this ,but not yet…

I think my situation is the same as this thred.
forums.asterisk.org/viewtopic.php?p=172431
This questionnaire seems to have succeeded in slove the problems,but There is no information how…
UDP must be relevant with this problem though…

Thank you for your all help.

Hi

I was little bit confused.
However finally I made it.

write

‘nat=yes’

in each user setting in user.conf or sip.conf
Thank you for your support.