[Help] Asterisk+Video ?%$#


#1

hello, it’s me… again

I tried all! *@h 1.3, 1.5, 2.0 BETA 3. With eyeBeam 1.1 3010n. I followed all this instructions but, nothing at all! It’ amazing! I do every thing whit my *@H (std fonctions :wink: ) The video don’t works.

This link dont help me: - voip-info.org/wiki/view/Aste … en+eyeBeam

I know, it’s the third time I request your help for the samething, somes guys tried to help me before but, all that a tried was not helpfull.

I connect to FWD and it’s work, i know it’s in my *Server

Here my sip.conf

; Note: If your SIP devices are behind a NAT and your Asterisk
; server isn’t, try adding “nat=1” to each peer definition to
; solve translation problems.

[general]
videosupport=yes ; enable Asterisk video support
port = 5060 ; Port to bind to (SIP is 5060)
bindaddr = 0.0.0.0 ; Address to bind to (all addresses on machine)
disallow=all
allow=ulaw
allow=alaw
allow=h263 ; H.263 is our video codec
allow=h263p ; H.263p is the enhanced video codec
context = from-sip-external ; Send unknown SIP callers to this context
callerid = Unknown

[200]
type=friend
username=Yan
secret=hidden
host=dynamic
context=internal
callerid=Video Phone <200>
disallow=all ; better for custom-tunning codec selection
allow=ulaw
allow=alaw
allow=gsm
allow=h263 ; H.263 is our video codec
allow=h263p ; H.263p is the enhanced video codec
dtfmode=rfc2833 ; inband is not supported in compressed codecs like gsm, so we better set it to rfc2833
canreinvite=no ; canreinvite must be set to ‘no’

[201]
type=friend
username=France
secret=hidden
host=dynamic
context=internal
callerid=Video Phone <201>
disallow=all ; better for custom-tunning codec selection
allow=ulaw
allow=alaw
allow=gsm
allow=h263 ; H.263 is our video codec
allow=h263p ; H.263p is the enhanced video codec
dtfmode=rfc2833 ; inband is not supported in compressed codecs like gsm, so we better set it to rfc2833
canreinvite=no ; canreinvite must be set to ‘no’

[202]
type=friend
username=Christian
secret=hidden
host=dynamic
context=internal
callerid=Video Phone <202>
disallow=all ; better for custom-tunning codec selection
allow=ulaw
allow=alaw
allow=gsm
allow=h263 ; H.263 is our video codec
allow=h263p ; H.263p is the enhanced video codec
dtfmode=rfc2833 ; inband is not supported in compressed codecs like gsm, so we better set it to rfc2833
canreinvite=no ; canreinvite must be set to ‘no’

#include sip_nat.conf
#include sip_custom.conf
#include sip_additional.conf


#2

Start the video on both ends, then place the call on hold, take it off hold, video works. If not, have the other party place you on hold and off again. I don’t know why you have to do this, found it on another forum, works for me.


#3

Hi Nick…have you being able to fix?


#4

Nick, I have it working at last…Heres the solution

Make sure you specify the video codecs in the [general] section of sip.conf

[general]
videosupport=yes
disallow=all
allow=alaw
allow=h263p

In eyebeam make sure you have h263+ selected as h263+ is equal to h263p

Also to get the video working you need to press hold on each client first and then the video works.


#5

[quote=“mtyoung”]Nick, I have it working at last…Heres the solution
[/quote]

Lucky you! When I put “videosupport=yes” asterisk thinks taht all phones all allways in use. When I coment this line, I can call SIP softphones normaly.

Do you know why this happends?


#6

The simple solution to that should be to put the following entry in the config stanza for each non-video phone:

disallow=h263p


#7

Well, if sip.conf follows the zapata.conf design, then the order matters. Any config below this line would inherit the setting. That’s my guess. But I’ve only been learning Asterisk for about a week, so I don’t really know.

SWB


#8

[quote=“WillKemp”]The simple solution to that should be to put the following entry in the config stanza for each non-video phone:

disallow=h263p[/quote]

I don’t have any non-video phone. All of them are eyeBeam.