Voice not heard after 20 secs

This is my first post, so bear with me and let me know if i miss something.

I have Asterisk 1.2.18 running on a PIII 667 mHz, 512mb ram. Running the demo setup where u get the congratulation prompt…
NO fxo/fxs or t1 etc cards.
X-lite soft phone client is connecting from mac.

Everything works if i access it from within my local lan, but if i connect it from work the audio stop after 20 secs (almost always 20 secs once i noticed 21 sec, tried it about a dozen time) and the line seems active i.e. x-lite doesn’t hangup or anything.

has anyone noticed anything similar ?

do u know what the problem could be ?
Any input would be helpful.

how does vonage and lingo etc,
make sure that their voip impl works behind routers without asking users to
open any ports etc etc.

any insight would be appreciated.

seriously, no one has any answers or is it that folks are just overwhelmed with the questions.

Ok once more, PLEASE can any one answer my original question as asked in previous posts.
thanks !

I’ve a customer that has a similar problem, with a small italian itsp provider, outgoing calls are working fine but every incoming call is closed by Asterisk after 20 seconds or something very close, if put a Snom phone in place of the Asterisk box everything works fine; I’m sorry but we haven’t find a solution until now, to me is clear that Asterisk and itsp proxy are not fully compatible but I don’t know if it’s a problem of the itsp or an Asterisk bug.


Hi mbruni,
thanks for your input. so you are saying replacing the asterisk box with a voip phone solved it.
so then who’s handling all the end points and the call setup ?

On a different note, are there more people who have experienced a similar problem
if you post your comments too and if there are quite a few of us, maybe someone from asterisk development would look into it more seriously.


  1. 2 Snom phones <-> Asterisk <-> itsp; inbound calls not working.
  2. 1 Snom phone <-> itsp; inbound calls working.