Viatalk and Asterisk in West Coast... ISSUES

I don’t understand, I did everything I could, I demilitarized my asterisk, I changed all the information as they requested… but still nothing, I still get these problems…

[2008-08-14 13:20:26] NOTICE[14334]: chan_sip.c:15884 sip_poke_noanswer: Peer ‘viatalk’ is now UNREACHABLE! Last qualify: 115
[2008-08-14 13:20:38] NOTICE[14334]: chan_sip.c:12700 handle_response_peerpoke: Peer ‘viatalk’ is now Reachable. (1287ms / 2000ms)
[2008-08-14 13:21:41] NOTICE[14334]: chan_sip.c:12700 handle_response_peerpoke: Peer ‘viatalk’ is now Lagged. (3195ms / 2000ms)
[2008-08-14 13:22:04] NOTICE[14334]: chan_sip.c:12700 handle_response_peerpoke: Peer ‘viatalk’ is now Reachable. (77ms / 2000ms)
[2008-08-14 13:24:08] NOTICE[14334]: chan_sip.c:15884 sip_poke_noanswer: Peer ‘viatalk’ is now UNREACHABLE! Last qualify: 85
[2008-08-14 13:24:19] NOTICE[14334]: chan_sip.c:12700 handle_response_peerpoke: Peer ‘viatalk’ is now Reachable. (1176ms / 2000ms)
[2008-08-14 13:26:24] NOTICE[14334]: chan_sip.c:15884 sip_poke_noanswer: Peer ‘viatalk’ is now UNREACHABLE! Last qualify: 289
[2008-08-14 13:27:03] NOTICE[14334]: chan_sip.c:12700 handle_response_peerpoke: Peer ‘viatalk’ is now Reachable. (1130ms / 2000ms)
[2008-08-14 13:28:06] NOTICE[14334]: chan_sip.c:12700 handle_response_peerpoke: Peer ‘viatalk’ is now Lagged. (3130ms / 2000ms)
[2008-08-14 13:28:16] NOTICE[14334]: chan_sip.c:12700 handle_response_peerpoke: Peer ‘viatalk’ is now Reachable. (116ms / 2000ms)
[2008-08-14 13:30:32] NOTICE[14334]: chan_sip.c:7573 sip_reg_timeout: – Registration for ‘XXXXXXXX@216.246.105.146’ timed out, trying again (Attempt #1)

sip.conf

[general]
context=default
bindport=5060
port=5060
bindaddr=0.0.0.0
externip=MY_EXTERNAL_DYNDNS_HOSTNAME
localnet=192.168.1.0/255.255.255.0
externrefresh=60
srvlookup=yes
;dtmfmode=inband
;dtmf=inband
ignoreregexpire=yes
dtmfmode=rfc2833
relaxdtmf=yes
disallow=all
allow=ulaw
allow=alaw
allow=gsm
nat=no
trustrpid=yes
sendrpid=yes
UserAgent=Asterisk
realm=asterisk

; REGISTRATION
register => XXXXXXXX:XXXXXXX@sanfrancisco-1.vtnoc.net/XXXXXXXX

; TRUNK CONFIGURATION
[viatalk]
type=peer
authuser=XXXXXXXXXX
username=XXXXXXXXXXX
fromuser=XXXXXXXXXXX
fromdomain=MY_EXTERNAL_DYNDNS_HOSTNAME
defaultip=sanfrancisco-1.vtnoc.net
host=dynamic
secret=XXXXXXXXX
nat=no
canreinvite=yes
insecure=very
qualify=yes
context=viatalk
dtmfmode=inband
dtmf=inband

this is the peer channel when I get lagged

* Name : viatalk
Secret :
MD5Secret :
Context : viatalk
Subscr.Cont. :
Language :
AMA flags : Unknown
Transfer mode: open
CallingPres : Presentation Allowed, Not Screened
FromUser : XXXXXXXXX
FromDomain : sanjose-1.vtnoc.net
Callgroup :
Pickupgroup :
Mailbox :
VM Extension : asterisk
LastMsgsSent : 32767/65535
Call limit : 0
Dynamic : No
Callerid : ""
MaxCallBR : 384 kbps
Expire : -1
Insecure : port,invite
Nat : RFC3581
ACL : No
T38 pt UDPTL : No
CanReinvite : Yes
PromiscRedir : No
User=Phone : No
Video Support: No
Trust RPID : Yes
Send RPID : Yes
Subscriptions: Yes
Overlap dial : Yes
DTMFmode : inband
LastMsg : 0
ToHost : sanjose-1.vtnoc.net
Addr->IP : 216.246.105.146 Port 5060
Defaddr->IP : 0.0.0.0 Port 0
Def. Username: 16192414397
SIP Options : (none)
Codecs : 0xe (gsm|ulaw|alaw)
Codec Order : (ulaw|alaw|gsm)
Auto-Framing: No
Status : LAGGED (2085 ms)
Useragent :
Reg. Contact :

am I doing something wrong?