Verbose Logging Goes Away


I’m using asterisk on debian etch. I had been using a startup script in /etc/init.d/ that uses safe_asterisk. The problem was that when starting asterisk using that script, my SSH session would hang when trying to exit. So, I decided to use the official “rc.debian.asterisk” script from the source’s contrib/init.d directory. That script enables me to start asterisk and exit from the ssh session without the session hanging. The problem is that the official rc.debian.asterisk script seems to eat verbose logging.

When I start asterisk with rc.debian.asterisk, the request to use messages to receive verbose level logging seems to be ignored. If I use the old script with no other changes I get verbose logging.

Here’s the relevant line from logger.conf:
messages => dtmf,notice,warning,error,debug,verbose

Any ideas?

In asterisk.conf, there’s an [options] context:


Change those to meet your needs.

Thanks for the reply. This worked.