/usr/sbin/dahdi_genconf: missing default group (termtype=UNK


#1

I have compiled Asterisk 1.8 from source, as well as the Dahdi software from source.

After running “dahdi_genconf” I get the error:

When I check in /etc/dahdi/system.conf I see the following: (I have also tried changing unknown to “te” but then the /etc/asterisk/dahdi-channels.conf file doesn’t seem to be created properly)

[code]# Autogenerated by /usr/sbin/dahdi_genconf on Tue Aug 9 08:31:15 2011

If you edit this file and execute /usr/sbin/dahdi_genconf again,

your manual changes will be LOST.

Dahdi Configuration File

This file is parsed by the Dahdi Configurator, dahdi_cfg

Span 1: WCT1/0 “Wildcard TE122 Card 0” (MASTER) B8ZS/ESF ClockSource

span=1,1,0,esf,b8zs

termtype: unknown

bchan=1-23
dchan=24
echocanceller=mg2,1-23

Span 2: WCTDM/0 “Wildcard TDM410P”

fxoks=25
echocanceller=mg2,25
fxoks=26
echocanceller=mg2,26
fxsks=27
echocanceller=mg2,27
fxsks=28
echocanceller=mg2,28

Global data

loadzone = us
defaultzone = us
~
[/code]


#2

I am getting same error message. I installed AsteriskNOW 1.7.1 32bit and did yum update before running dahdi_genconf. I’m using TE122B card.

From the source code /usr/lib/perl5/site_perl/5.8.8/Dahdi/Span.pm I see that the span type if being set to T1_UNKNOWN which is not found in the hash of supported types, e.g. T1_TE or T1_NT are expected. If I am reading this right it sets span type value based on the card model name obtained from /proc/dahdi/ and in case of some cards it can not do it, so I guess there might be come config file setting to manually set it (I’ve not yet gone deep enough to see if it reads any).

I am a new to Asterisk I don’t know where to look now, other than keep reding the source. Pointer in the right direction would be nice. Thanks.


#3

I was told by digium that it was a bug in the latest version of Dahdi. I ended up downloading a slightly older version of Dahdi and compiled it and this error went away. Hope this helps.


#4

Hi wrender - did you get any reference number for the bug in the latest version of dahdi? I could not find anything that matched this in the Digium issue tracker, and I need to get Dahdi 2.5.0 working.


#5

Bugs detected as part of Digium’s commercial support don’t necessarily find their way into the open source bug tracker.


#6

I solved this by dowgrading dahdi-tools package to version 2.4.1-1.

I’m using AsteriskNOW-1.7.1. Version of dahdi-tools installed from the CD works fine. Upgrading all packages to latest breaks dahdi_genconf so I downgrade just the one package as a work around.


#7

I upgraded dahdi-tools to version 2.5.0.2-1 and I no longer have this problem.


#8

Just noting that this was the issue reported in DAHTOOL-55.