"Username/auth name mismatch" + SIP phone can't co

Hello

I'm trying to set up Asterisk on an older AMD Duron 700MHz with Fedora 5 for use with SIP phones and the Linksys 3102 SIP gateway (ie. no FXO card, so no need for zaptel and libpri), but I'm stuck: The GrandStream BudgeTone phone fails registering with Asterisk :-/

Following the “Asterisk - The Future of Telephony.pdf”, here’s what I did:

  1. Installed Fedora 5, and ran “yum update”, followed by “rpm -Uvh kernel kernel-devel” (yum would download the i686 version of “kernel” but the i586 version of “kernel-devel”). I made sure it had all the requirements for Asterisk (ncurses + ncurses-devel, openssl + openssl-devel, zlib + zlib-devel, and bison)

  2. Downloaded, unzipped, built, installed the following packages succesfully:
    asterisk-1.2.13
    asterisk-sounds-1.2.1

  3. Edited /etc/asterisk/sip.conf thusly:
    [200] ; extension 200
    type=friend
    secret=test
    qualify=yes ; Qualify peer is no more than 2000 ms away
    nat=no ; This phone is not natted
    host=dynamic ; This device registers with us
    canreinvite=no ; Asterisk by default tries to redirect
    context=internal ; the internal context controls what we can do

  4. Added an empty section at the bottom of /etc/asterisk/extensions.conf:

[internal]
;later

  1. Launched asterisk -vvvvvgc. Launches with no error message

  2. Configured the GrandStream phone with user=200, authname=200, password=test, SIP server=192.168.0.252 (IP of Asterisk server), register=yes

  3. When I plug/unplug the SIP phone, its network icon isn’t displayed (ie. there’s no connection with the SIP server, and no dial tone), and here’s what /var/log/asterisk/messages says:

Nov 13 19:52:33 NOTICE[17922] chan_sip.c: Registration from ‘sip:200@192.168.0.252’ failed for ‘192.168.0.234’ - Username/auth name mismatch

=> Is this due to wrong settings in sip.conf, the empty section in extensions.conf, the fact that I didn’t add the Linksys gateway yet (how?), something else?

Thank you for any tip
Fred.

try adding “username=200” to the entry in sip.conf

Thanks. Turns out the hardphone was still set to use NAT/STUN. I turned this off, added a couple of extensions in the dial plan, and it worked :smile: