Can not register SIP phones. What am I missing?

Sorry for the basic question, but I have spent hours trying to figure this out. Finally decided to tap into the A* community for some help.

Thanks in advance for any help. :smiley:

I have a new install on Asterisk (installed via AsteriskNOW) and am trying to get my two SIP phones to register. I have set them up in the GUI as extensions 10 and 11 with passwords 10 and 11 respectively.

On my Grandstream BT101 phones I have the SIP Server and outbound Proxy set to (the IP of the server) with port 5060. The SIP User ID, Authenticate ID, and Authenticate Password are all set to 10 or 11 for each phone.

Command> sip show peers

Name/username Host Dyn Nat ACL Port Status
11 (Unspecified) D 0 Unmonitored
10 (Unspecified) D 0 Unmonitored
trunk_1/8304335313 5060 Unmonitored
3 sip peers [Monitored: 0 online, 0 offline Unmonitored: 1 online, 2 offline]

I can ping the server. The phones and server are on the same switch so I do not think there could be a firewall issue.

I sure would like to get this working today. Thanks again for any help.


While you’re in the asterisk CLI prompt, try to register a phone and see if any messages pop up in asterisk saying that it’s trying to register. It sometimes will give you a hint (such as bad password, username/auth name mismatch)

You may want to type ‘sip set debug’ to figure out what’s really going on.

You may also want to leave the auth name blank. I know with my server, I only need to input the username and password on all my phones and just leave the auth name blank.

If you do have CLI messages regarding these phones though post them and we’ll take a look and see if we can figure out what’s happening

I had problems connecting my D-LINK ip phones to asterisk. After trying all kinds of things that didn’t help i decided to start over with a basic extension setup where i left out the password and that worked.
Because i’m using it at home i didn’t try getting it to work with a password after that.
It might be something you can try. (Don’t forget to put on the password back on it afterwards :wink: )

I finally got this working. I was using a Linksys router and even though I had the firewall turned off and it was supposed to be acting as just a switch, it was not allowing the traffic on 506. I switched to another switch I had and it worked. I wasted 2 day son that one. :angry: :blush: