Unable to install G729

Newbie so please be gentle, I purchased a G729 license from Digium & then tried to follow their instructions. Unfortunately I fell at the first hurdle.

[root@sip ~]# wget downloads.digium.com/pub/registe … 2/register
–13:30:12-- downloads.digium.com/pub/registe … 2/register
Resolving downloads.digium.com…, 2001:470:e0d4::e8
Connecting to downloads.digium.com||:80… connected.
HTTP request sent, awaiting response… 200 OK
Length: 1178780 (1.1M) [text/plain]
Saving to: `register.1’

100%[====================================================================================================>] 1,178,780 561K/s in 2.1s

13:30:14 (561 KB/s) - `register.1’ saved [1178780/1178780]

[root@sip ~]# cd /
[root@sip /]# /root/register

Digium Product Registration - Version 3.0.5
Copyright © 2004-2007, Digium, Inc.
Use the ‘-l’ option to see license information for software
included in this program.

Could not generate Host-ID.
Make sure that you have eth0 enabled.
[root@sip /]#

I contacted my server provider to see if they could shed any light & their response was

“Since this is a PV server this have venet0:0 and I have made sure that it is up and enabled without any issues.”

Is there a way to do this or am I stuffed?



I believe this is as supported product, so you should use support@digium.com.

Does your network interface have a MAC address?

Thank you for the swift response, I tried to use their website & all I could find were support which required payments. I have also found since posting 2 more sites,

sysadminman.net/blog/2009/instal … vz-vps-804

Virtually same instructions, however I do not have the vzctl command available. I have tried to install it via yum but ti come back with not found. I have raised a ticket with my vps provider. I do not have a dedicated MAC address.



I would ask you VPS provider if they have a XEN based hosting solution. XEN will give you the eth0 that the register utility is looking for.

You shouldn’t run asterisk on a VM machine unless you have total control of the host, so as to give asterisk priority and avoid overloading it.

Well got in contact with my VPS company & they provided a MAC so the register part completed, however now I’m stuck on the next bit, this is not going well. From


I am trying to

wget downloads.digium.com/pub/telephony/codec_g729/
benchg729/x86-32/benchg729-1.0.7-x86_32 -O benchg729

All I get is

[root@sip ~]# wget downloads.digium.com/pub/telephony/codec_g729/\

      benchg729/x86-32/benchg729-1.0.7-x86_32 -O benchg729

–10:54:19-- downloads.digium.com/pub/telephony/codec_g729/
Resolving downloads.digium.com…, 2001:470:e0d4::e8
Connecting to downloads.digium.com||:80… connected.
HTTP request sent, awaiting response… 200 OK
Length: unspecified [text/html]
Saving to: `benchg729’

[ <=>                                                                                                 ] 2,972       --.-K/s   in 0s     

10:54:19 (202 MB/s) - `benchg729’ saved [2972]

–10:54:19-- benchg729/x86-32/benchg729-1.0.7-x86_32
Resolving benchg729…
Connecting to benchg729||:80… failed: Connection timed out.

–10:57:29-- (try: 2) benchg729/x86-32/benchg729-1.0.7-x86_32
Connecting to benchg729||:80… failed: Connection timed out.

–11:00:40-- (try: 3) benchg729/x86-32/benchg729-1.0.7-x86_32
Connecting to benchg729||:80…

Which eventually times out with message ‘Giving Up’

Has a link changed?




downloads.digium.com/pub/telepho … benchg729/

there are two subdirectories there, one for x86 and one for x86-64, that’ll lead you to:

downloads.digium.com/pub/telepho … 0.8-x86_32


downloads.digium.com/pub/telepho … 0.8-x86_64


Thanks Malcolm I ended up getting a link from support

downloads.digium.com/pub/telepho … 729/README

I followed the instructions on there & got it working, however even these are out of date as benchg729-1.0.7-x86_32 -O is now benchg729-1.0.8-x86_32 -O



The README contains examples, it’s assumed that the user will generally download the newest version of what’s available. That may be a bad assumption. :frowning:

Hi… I am having some problem installing the bench files…

I first tried
cd /root

wget downloads.digium.com/pub/telephony/codec_g729/\

benchg729/x86-32/benchg729-1.0.7-x86_32 -O benchg729

but it showed an error… after reading this post i tried using benchg729/x86-32/benchg729-1.0.8-x86_32 -O benchg729

after running the bench utility /root/benchg729 it is showing an error like this:
/root/benchg729: line 1: --2012-04-13: command not found
/root/benchg729: line 2: Resolving: command not found
/root/benchg729: line 3: Connecting: command not found
/root/benchg729: line 3: command not found
/root/benchg729: line 3: :80…: command not found
/root/benchg729: line 4: HTTP: command not found
/root/benchg729: line 5: 2012-04-13: command not found

Please help me! I am total newbie to asterisk…

That’s because you’re trying to wget a file that isn’t there.

Note to people who read this thread in the future. Versions change. Browse to the directory (use a web-browser or lynx or links or something you prefer), and then download the latest file.

The file today is:

downloads.digium.com/pub/telepho … 0.8-x86_32

If the version changes, you won’t be able to download that particular file. Instead, open your browser (or whatever) to:

downloads.digium.com/pub/telepho … 29/x86-32/

Get the exact URL of the file you need, since it may have changed, and then wget that, whatever it is.