Problems installing G729 codec

I tried to install the g729 codec from Digium and it appeared to install, but then I saw that I needed to have my interface named eth0, not eth1, and mine is set at eth1. Any idea how to change my interface name from eth1 to eth0?

When I try to make a call from eyebeam using the g729 codec, it says that Call Failed: Not acceptable here. It only gives that when I use the g729 codec, if I use the g711 codec, it works just fine.

Since I get this error in eyebeam both before installing the g729 on the asterisk server, and after, I figure that the registration of the licenses probably did not work.

When I do a show g729 in the cli, it says that I have 0/0 of 20 licenses being used, so it sort of looks like they are registered, but they still do not work.

Any suggestions?


It seems that it is working being that it shows up on your box. Did you try another soft phone ? If you still have issues give Digium a call. Also what so they asterisk logs show ?

Figured out that I did not enable it for any of the extensions. After I did that, then they worked.