OK…So here is the latest on my learning stuff.
I’ve successfully installed and configured asterisk on Ubuntu server at home…but who wants to only work on somethign at home :->…long and short though it works fine.
Now at work I have an ESXi 3.5 server, so I figured why not create a VM and install ubuntu server 9.x on it and asterisk so I can play at work(lots more hardware and bandwidth here).
anyhow the strange thing is that I"ve installed it no problem, and it’s running(pretty sure).
when I try to connect to the service using asterisk -r (or vvvvvvvvvvvr) I get an error “unable to connect blah blah”…now I had the same problem at home, found out I need to run the command using sudo asterisk -r and it connects fine…
So googling around I see everyone saying to check /var/run/asterisk for a .ctl and .pid file, and they do exist on this install…for a fun test I deleted these files and rebooted(someone recommended that somewheere).
Anyhow I reboot, as I watch I see the console report that it’s starting asterisk…log in as my user and check the /var/run/asterisk folder and the files are back as expected…run the command sudo asterisk -r and I get the same error…unable to connect.
Funny thing is I went through what I thought was the same steps as on my home box…but obviously something is differnet :->. The only thing I can think of that is diferent is that I’m running on VMware esxi…but that shouldn’t really effect anything other than performance one would think.
So I"m a linux newbie, not sure what the deal is here…any other ideas?
Here is some info about this install:
Ubuntu 32bit server(current version) installed originally with just open SSH
Installed all the requirements for DAHDI and asterisk
Installed from source dahdi-linux-complete-2.2.1+2.2.1
Install from source Asterisk-1.6.2.5(asterisk-1.6.2-current.tar.gz)
Linux version is 2.6.31-14
used sudo make config to get it to load at boot.
Other things I’ve noticed that may help:
If I run the command sudo service --status-all just about everything shows as [?], so I’m assumign it’s some permissions thing, but I haven’t set up any user accounts other than mine(with ubuntu you don’t/can’t log in as root…everything as sudo).
Any tips would be greatly appreciated.
thanks
Josh