Unable to configure third-party/pjproject


#1

hi,

I’m new in Asterisk i have tried to install it on centOs i was stacked in the below step
i have installed the dependencies but i got the same error any help please ?

pjproject] Downloading https://raw.githubusercontent.com/asterisk/third-party/ master/pjproject/2.6/pjproject-2.6.tar.bz2 to /tmp/pjproject-2.6.tar.bz2
make: *** [/tmp/pjproject-2.6.tar.bz2] Error 4
make: *** Deleting file `/tmp/pjproject-2.6.tar.bz2’
failed
configure: Unable to configure third-party/pjproject
configure: error: Re-run the ./configure command with ‘NOISY_BUILD=yes’ appended to see error details.
[root@localhost asterisk-15.0.0]#


#2

Have you re-run the configure command as stated to see the error details?


#3

i didn’t understand it
make: *** [/tmp/pjproject-2.6.tar.bz2] Error 127
make: *** Deleting file /tmp/pjproject-2.6.tar.bz2' make: Leaving directory/usr/src/asterisk-15.0.0/third-party/pjproject’


#4

You need to run “./configure NOISY_BUILD=yes” and provide the output at the bottom where it states the error.


#5

i think the link below is inaccessible when in run .\configure how can i skiped i will download it from another path ,

https://raw.githubusercontent.com/asterisk/third-party/master/pjproject/2.6/pjproject-2.6.tar.bz2 to /tmp/pjproject-2.6.tar.bz2


#6

When you run ./configure, you can set the PJPROJECT_URL environment variable to point to an alternate site.
Example:

# ./configure --with-pjproject-bundled PJPROJECT_URL=http://pjsip.org/release/2.6


#7

a same error :frowning:
can i skip this download ?


#8

I made re install the asterisk 11…


#9

Asterisk 11 reaches End-of-Life (EOL) next week. Therefore, I recommend investigate this issue in more detail. In your folder ‘/tmp’, is there still the file ‘pjproject-2.6.tar.bz2’? If yes, please, remove that manually. Then, give (the non-certified) Asterisk 13 LTS a go. That variant does not build the PJProject on default. Therefore it should do. When ‘./configure’ works, try ‘./configure --with-pjproject-bundled’ and post the results! Perhaps you have a permission thing about your tmp folder? By the way, which version of CentOS are you using?


Build failure of 15.1.0
#10

thanks for the feedback for the centOs version is CentOS-6.9


#11

Were you able to investigate further? Are you on a resource constraint device like a Raspberry Pi?

What happens, when you go for
wget -O- --timeout=5 https://raw.githubusercontent.com/asterisk/third-party/master/pjproject/2.6/pjproject-2.6.tar.bz2 > /tmp/pjproject-2.6.tar.bz2


#12

I reported what appears to be possibly the same error with 15.1 a few days ago. I ran NOISY_BUILD and it didn’t produce any useful information but after a few messages back and forth from traud and examining the Makefile for pjproject it appears a call to the DOWNLOAD_TIMEOUT function is likely timing out on a dns_timeout of 5 seconds. I haven’t tried modifying the Makefile because I already got 15.1 to install by using with-externals-cache as shown on the wiki.


#13

I recently decided to build a new asterisk 13 server on and discovered I had the same issue as this one the issue decided to follow me if I tried to compile for asterisk 15 as well. As proftech eluded looks like its a dns related issue. Adjusting DOWNLOAD_TIMEOUT to 10 from 5 in ./third-party/pjproject/Makefile successfully corrected the problem. Hope this helps any future visitors