Pjproject failing to verify and install

I’m trying to install Freepbx on centos 7 and while I’m trying to install asterisk it keeps failing when I run the ./configure command. I’ve tried running it as ./configure --libdir=/usr/lib64 --with-jansson-bundled, I’ve tried ./configure --libdir= /usr/lib64 --with-pjproject-bundled and it still fails.

this is what I get from the server:

[pjproject] Verifying /tmp/pjproject-2.12.1.tar.bz2
[pjproject] Verify failed
[pjproject] Retrying download
[pjproject] Downloading https://raw.githubusercontent.com/asterisk/third-party/master/pjproject/2.12.1/pjproject-2.12.1.tar.bz2 to /tmp/pjproject-2.12.1.tar.bz2
[pjproject] Unpacking /tmp/pjproject-2.12.1.tar.bz2

bzip2: Compressed file ends unexpectedly;
perhaps it is corrupted? Possible reason follows.
bzip2: Inappropriate ioctl for device
Input file = (stdin), output file = (stdout)

It is possible that the compressed file(s) have become corrupted.
You can use the -tvv option to test integrity of such files.

You can use the `bzip2recover’ program to attempt to recover
data from undamaged sections of corrupted files.

/bin/tar: Child returned status 2
/bin/tar: Error is not recoverable: exiting now
mv: cannot stat ‘pjproject-2.12.1’: No such file or directory
make: *** [source/.unpacked] Error 1
configure: Unable to configure third-party/pjproject
configure: error: Re-run the ./configure command with ‘NOISY_BUILD=yes’ appended to see error details.

I’ve tried running it with NOISY_BUILD=yes as well.

Please can anyone help

First run this cmd:
wget -O /tmp/pjproject-2.12.1.tar.bz2 https://raw.githubusercontent.com/asterisk/third-party/master/pjproject/2.12.1/pjproject-2.12.1.tar.bz2

Then: ./configure --libdir=/usr/lib64 --with-jansson-bundled

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.