Trying to install freepbx 14 on Ubuntu 16.04 with Asterisk 13.16 - Error: can't communicate with asterisk, asterisk appears to be running as asterisk


#1

Since I don’t receive the confirmation mail from the freepbx community I’m forced to post my question here.

As the title says I’m trying to install freepbx. The error message is: Error! Error communicating with Asterisk.Ensure that Asterisk is properly installed as the asterisk user Asterisk appears to be running as asterisk Try starting Asterisk with the ‘./start_asterisk start’ command in this directory

Note that I have actually run ./start_asterisk start and got this error message.

Obviously I can run asterisk as the user asterisk so the problem probably isn’t the permissions.

I’ve tried with starting asterisk as a daemon on the user asterisk but I still get the same error message.

I have installed all dependencies listed on https://wiki.freepbx.org/display/FOP/Installing+FreePBX+13+on+Ubuntu+Server+14.04.2+LTS

but instead of php5 I’ve installed php7.0 which should be compatible with freepbx 14.

I don’t know what else to tell so if something is unclear ask me. I hope you guys can help me.


EDIT:

I’ve managed to get past this problem. I’ve discovered this page: https://antonraharja.com/2016/03/12/asterisk-13-and-freepbx-13-on-ubuntu-14-04/ and did the missing steps.

I also had to create an asterisk folder in the home directory and gave asterisk ownership. running ./install -n again I get this error message:

[Doctrine\DBAL\Exception\DriverException] An exception ocurred while executing ‘CREATE TABLE freepbx_log (id INT AUTO_INCREMET NOT NULL, time DATETIME DEFAULT ‘0000-00-00 00:00:00’ NOT NULL, section VARCHAR(50) DEFAULT NULL, level VARCHAR(255) DEFAULT ‘error’ NOT NULL, status INT DEFAULT 0 NOT NULL. message LONGTEXT NOT NULL, INDEX time(time,level), PRIMARY KEY(id)) DEFAULT CHARACTER SET utf8mb4 COLLATE utf8mb4 COLLATE utf8mb4_uni code_ci ENGINE = InnoDB’: SQLSTATE[42000] Syntax error or access violation: 1067 Invalid default value for ‘time’

I still want to install freepbx. Is this possible or is this error a bug?