Trouble with dtmf detect

Asterisk does not detect dtmf signals of some subscribers from pri. I see this problem in Asterisk. I have cisco 5350 which normal detect signals from the problem (for Asterisk) subscribers from pri.

What do ?

Are you using a Digium card to terminate that PRI?

You can use pri debug to see more. Make sure 5350 can send dtmf…

what the hardware and software environments? show the debug info, please.

I have a digium te220b card … and I had a dtmf problems tooo … and problem was with echo canceler … that canceled some of dtmf signals too :smile: IF you have echo canceler … tray to turn it off

yes, Wildcard TE210P (4th Gen)

no, i tried to use instead of Asterisk the 5350 and everything worked.

My schema :
Other PBX -pri- Asterisk PBX , from SOME subscribers of the “Other PBX” dtmf don’t work
but if :
Other PBX -pri- Cisco 5350 , dtmf always work

[quote=“james.zhu”]show the debug info[/quote]In logs about dtmf nothing (from problem subscribers), because Asterisk does not detect the dtmf.

[quote=“”]IF you have echo canceler … tray to turn it off[/quote]yes, i am using mg2… will try use oslec.

If you’re using a Digium card and having trouble, please contact our Support department directly. We (Digium) don’t do Support via these forums - they’re a community resource.

Contact details are contained in this thread: