Asterisk detect DTMF problem

I’m building a menu. Like this :

exten => s,1,Background(welcome)
exten => s,2,Background(guide)
exten => s,3,WaitExten(20)

exten => 1,1,Goto(Music,s,1)
exten => 2,1,Goto(Sport,s,1)
exten => 3,1,Goto(News,s,1)
exten => 4,1,Goto(Social,s,1)

exten => *,1,Goto(s,2)
exten => #,1,Goto(s,2)

exten => h,1,HangUp()
exten => i,1,Goto(s,2)
exten => t,1,Goto(s,2)

But when the user press the keys number (1,2,3,4), sometime asterisk detect DTMF, sometime not. I cannot understand what lead to this trouble.
Please help me.

In most cases when I had similar problems like missing DTMF or doubled DTMF were solved switching provider.

Now this needs to be a sticky :wink:.

im logger.conf enable full and add dtmf to the logging. Restart the logging on Asterisk and see if it comes in when you press by doing tail -f /var/log/asterisk/full. If not your carrier may have some issues. In general it’s best to test locally with a phone to rule out carrier issues. If it works all the time locally then you know you need a new carrier. It’s all about the process of elimination.

@bira_more : I’m new to asterisk so i don’t understand that how you solved this problem.

@Dovid : I’ve add dtmf logging and i found that in the case that asterisk doesn’t detect my keys, the digit didn’t appear.

And here is my system :
OS : CentOS 4.5
Sangoma Technologies Corp. A104d QUAD T1/E1 AFT card
Asterisk : i use astunicall 1.4.18, like this instroduction
My system use four E1 line.

Most likely problem with VoIP provider.
If you cant understand - please go and read
Asterisk The Future of Telephony.
My English is bad, and I cant explain better then in book.