Transport 'transport-tls' could not be started

Hi Guys,

I need your help with something.
I have been hitting my head against the wall for the last few hours.
First time seeing this error.

I am trying to make a transport for this within my pjsip configuration.
On other servers, it’s working fine, but with my Asterisk 16 server, I get the following error when I restart the asterisk.

[Mar 30 06:35:27] ERROR[1718] res_pjsip/config_transport.c: Transport 'transport-tls' could not be started: Unknown error -1
[Mar 30 06:35:27] ERROR[1718] res_sorcery_config.c: Could not create an object of type 'transport' with id 'transport-tls' from configuration file 'pjsip.conf'

I have tried a lot of things, but it doesn’t seem to show up under “pjsip show transports”.
I’m kind of clue less with this one. Google isn’t really helping also.

My current pjsip configuration.

; Pjsip Configuration
[transport-tls]
type=transport
protocol=tls
bind=0.0.0.0:5061
cert_file=/etc/asterisk/keys/asterisk.crt
priv_key_file=/etc/asterisk/keys/asterisk.key
method=sslv23

I hope anybody can point me In the right direction.

Thank you.

Wesley

Is it the same Linux distribution? Do you have all the dependencies installed (such as OpenSSL)?

I believe this message will only occur if PJSIP itself was built without support for TLS.

1 Like

Thank you.

Reinstalling the server did the trick.
I don’t know what went wrong with the previous install, but it works now after creating a new server and installing it again from step 1.