PJSIP - TLS transport dont load

Hi everyone.

I trying to configure TLS transport in my new project but for some reason doesnt work.
I cofingure the pjsip.conf like this:



But, when i use the command pjsip show transports, the tls transport dont load, just udp transport.

I search in the /var/log/messages for a sealert about something wrong, but found nothing.
Can you help me?

The module will load messages on startup if it fails to load for some reason, they are usually in /var/log/asterisk/messages or you can see them by manually starting Asterisk in your console.

I look on the file that you said. I found this:

[Mar 2 10:13:11] ERROR[2760] res_pjsip/config_transport.c: Transport: transport-tls: cert_file /home/asterisk/certs/self-signed.crt is either missing or not readable

So i changed the permissions of the file to 777 and the owner is the same user whos run asterisk, but still get the same message everytime i reload asterisk.

[astmin@localhost ~]$ ps -ef | grep asterisk
root 1519 1 0 10:15 ? 00:00:00 /bin/sh /usr/sbin/safe_asterisk
asterisk 1558 1519 0 10:15 ? 00:00:01 /usr/sbin/asterisk -f -vvvg -c

[astmin@localhost ~]$ sudo ls -l /home/asterisk/certs/
[sudo] password for astmin:
total 8
-rwxrwxrwx. 1 asterisk asterisk 1359 Mar 1 17:02 self-signed.crt
-rwxrwxrwx. 1 asterisk asterisk 1704 Mar 1 16:59 self-signed.key

So, notice that has a dot after the permissions, and search some info about that. I find something about this dot has a relation with selinux, so i turned selinux to “permissive”, just to see what happens. After that i don’t get more error messages of cert. How could i config selinux to work without disable it?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.