Training Busydetect?

Is there any way to tell asterisk what to look for in a busy or congested tone? I’ve made a recording of the one I’m getting, and that I’d like asterisk to detect:

I’m in the US, and this seems like an unusual busy tone. I suppose I coud tweak indications.conf, but I don’t know how to get the correct frequencies to put into that file. Any help would be appreciated!

Kindest Regards,

try 625hz/445hz :smile:

I’ve just finished trying that… in indications.conf, I’ve got (under [us]):

busy = 625/250,445/250

I’ve also tried setting the frequencies to 620 and 440, 610 and 430, 620 and 425. 've tried the cadence at both .25 and .26 (250 and 260).

in my zapata.conf, I’ve got busydetect=yes and busycount=2. With busycount, I’ve tried every value between 1 & 6.

Thinking about it though… The volumes on my TDM400 seem to be a bit soft. I’ve tried increasing the rxgain and txgain values to 3.0 each, but dont really notice a difference. Is it possible that by zapata.conf is being read (verbose mode when reloading indicates that asterisk is finding and parsing it) and somehow ignoring it?? Here’s what zapata.conf currently looks like:

; General Options

; FXO Modules

i could be wrong but I think many of the zaptel indications are hardcoded into zaptel somewhere… is this still true? If so you’d need to edit hte source and recompile for zap to see the difference…

A quick grep through the source indicates that indications is its own beast, and lies within the main asterisk source, not zaptel…

any other ideas? BTW< thanks for your suggestions thus far!


might be in * source then.

try creating a different ‘indications zone’ and set * to use that, most of it will be a copy of US excpet for busy…

[quote=“IronHelix”]might be in * source then.

try creating a different ‘indications zone’ and set * to use that, most of it will be a copy of US excpet for busy…[/quote]

I created a custom zone, called usc.

description = Custom United States / North America
ringcadence = 2000,4000
dial = 350+440
busy = 625/260,445/260
ring = 440+480/2000,0/4000
congestion = 480+620/250,0/250
callwaiting = 440/300,0/10000
dialrecall = !350+440/100,!0/100,!350+440/100,!0/100,!350+440/100,!0/100,350+440
record = 1400/500,0/15000
info = !950/330,!1400/330,!1800/330,0
stutter = !350+440/100,!0/100,!350+440/100,!0/100,!350+440/100,!0/100,!350+440/100,!0/100,!350+440/100,!0/100,!350+440/100,!0/100,350+440

Then I specified to use it as the default

country=usc             ; default location

Still no joy. I also tried specifying the tone length as both 250 and 260.

Anything else I could try?

Looks like the busydetect stuff is hardcoded into chan_zap.c and dsp.c. I’m not a very good C hacker, but I’ll poke it with a stick and see if I can make it work a bit more like I want it to. Anyone with more asterisk experience willing to point out any gotchas before I start?