Trailing IP on CallerID


#1

We have set up Asterisk 1.6.2.20 on CentOS (base package) with all of the bundled add-ons and configured one SIP trunk for incoming and outgoing calls.

We are using Cisco SPA303 phones and Blink as a softphone. Whenever we receive incoming calls on either the soft phone or the Cicsco phones we see the calling number trailing @ {Internal IP, XX.XXX.XX.XX}. Is there any way to remove the trailing IP from the caller ID number so that it just shows the number or just shows the extension?


#2

I have never seen this happening. All the phones I have used strip the @ and what follows.

On though though: some phones, if they are not registered, will present SIP URIs, but will also require you to dial using them.

Of course, it might be that something is duplicating the full address into the human readable part of the From header, but one would need to see a SIP trace to confirm that.


#3

Your SIP Trunk reference hints that you may be using a GUI, which would be an important fact and may render this forum inappropriate.

Also 1.6.2.x versions are on security fixes only, so should not be used for clean new installations.


#4

Thank you for the reply, david55.
When enabling “registersip” in the configuration file, I get a “rejected” message when running “sip show registry” in the console: {extension}:5060 REJECTED