Call-Id field in SIP Register Packet

I am having trouble registering a trunk with my service provider from my asterisk box, but I am able to use an ATA to register to my provider.

I have been doing “wireshark” captures of the SIP Registrations between the ATA and my provider and the Asterisks box and my provider and the difference I have noticed is the Call-Id line in the To section of the SIP packets are different.

The Call-Id line of my ATA has @MyPublicIpAddress and the Call-Id line of my Asterisks box is @

Can someone explain to me why my Asterisks box is adding the @ to the Register packet, and how I might be able to modify that to reflect a different ip address.

I have tried using the “externhost” option in my SIP.CONF file, but that make any difference with the Call-Id line of the Register Packet.

Any help you can provide would be greatly appreciated.