tdm400p no dialtone

hope you will find a sec to help with my newbish problem - here it is: when pressing the dial/green button on analog phone (connected to tdm400p/fxs port) I can not seem to get dialtone ;-(( What is more interesting, if I dial 500 and press dial(as in dialplan below), then for a short moment I am able to hear dialone, then phone dials and i am connected to echo function as in dialplan below, so in general this setup rather works but it does not detect the ‘offhook’ event. btw. when running asterisk -vvvvvc under console i see activity as well when i dial 500 and press dial/green button on the phone(message about switch being created for my zap interface), but nothing happens on the console when instead i just press the dial/green button…

tdm400p with 2xfxs ports (1&2)
gentoo 2.6.25-gentoo-r8

i tried with a few different tutors, currently i am configuring everything almost same way as in ‘asterisk, future of telephony’ book.


Span 1: WCTDM/0 “Wildcard TDM400P REV I Board 1” (MASTER)

loadzone = uk
defaultzone = uk

; Span 1: WCTDM/0 “Wildcard TDM400P REV I Board 1” (MASTER)
;;; line="1 WCTDM/0/0 FXOKS (In use)"
channel => 1
;;; line="2 WCTDM/0/1 FXOKS (In use)"
channel => 2

exten => s,1,Verbose(1|Unrouted call handler)
exten => s,n,Answer()
exten => s,n,Wait(1)
exten => s,n,Playback(tt-weasels)
exten => s,n,Hangup()
exten => 500,1,Verbose(1|Echo test application)
exten => 500,n,Echo()
exten => 500,n,Hangup()
include => internal

oh, yeah i read this forum and tried a few tips (reseating the card, reloading zapata/dahdi module in asterisk, using different psu for the card), nothing helped.

btw. I live in Ireland, analog phones are bought in ireland. still there is no definition of ireland in zonedata.c, that’s why i decided to use UK (tried US as well with same result). Could this be a problem? Do I need correct dial/busy tone definitions for these phones?
Or is this related to something I still have to learn about? :smile: Does it work as it should be? in the asterisk book I found a sentence informing that option ‘immediate=no’ should be actually responsible for enabling the ‘dial tone’… me confused :frowning:

I hope sbd can help me clarify this confusion.


looks like i have the answer (painfully newbish :blush: , but still going to share it, hopefully it helps sbd ) => never used the phone before (it’s siemens gigaset a160) and just found out that it is its nature (no dialtone unless dialing). always test your phone in normal pstn first (if you have one :wink: ) . different phone works exactly the way I expected.

i guess the whole confusion came from the fact that gigaset did not sent offhook signal till dialing, that’s why this message is displayed so late under asterisk: – Starting simple switch on ‘Zap/1-1’, and with normal you see it straight after pressing dial.