TDM22B configuration


#1

Hello.

I have just installed a TDM22B Digium card. I am located din Romania.
I read about loading the wctdm driver outside North America at
voip-info.org/wiki/view/TDM400P

So I added “options wctdm opermode=ROMANIA” in modeprobe.conf .
But in /var/log/messages I can see :
Module 0: Installed — AUTO FXS/DPO
Module 1: Installed — AUTO FXS/DPO
Module 2: Installed – AUTO FXO (ROMANIA mode)
Module 3: Installed – AUTO FXO (ROMANIA mode)

That means the tone dialing remained on US? (FXS are not in ROMANIA mode). There is no “ro” zone to set as loadzone and defaultzone.Does anyone know how can I set it?

I tested the FXO port with my local telephone line and I managed to call my local phone from another one. I used a simple dial plan to play a file.
The sound is heard, but at a small intensity. Can I make it to be heard loudly?

Mike


#2

I found this list of tones for evry country :
itu.int/ITU-T/inr/forms/files/tone-0203.pdf

I read also that I have to add the Romania country code to
zonedata.c and rebuild zaptel.

I came out with :

{ 100, “ro”, “Romania / Europe”, { 2000, 4000 },
{
{ ZT_TONE_DIALTONE, “450” },
{ ZT_TONE_BUSY, “450/170,0/170” },
{ ZT_TONE_RINGTONE, “450/1500,0/4500” },
/* Not sure about the rest */
{ ZT_TONE_CONGESTION, “450/250,0/250” },
{ ZT_TONE_CALLWAIT, “450/300,0/10000” },
{ ZT_TONE_DIALRECALL, “450” },
{ ZT_TONE_RECORDTONE, “1400/500,0/15000” },
{ ZT_TONE_INFO, “!950/330,!1400/330,!1800/330,0” } }
}

I found the information for dial, busy and ringtone, but not for the rest.

Anyway I suppose I can put now in this file (zonedata.c)
#define DEFAULT_TONE_ZONE 100 .

Is it the same if I will not modify zonedata.c and instead I will modify
indications.conf with the following??

[general]
country=ro
;
[ro]
description=Romania/ Europe
ringcadance=2000,4000
dial=450
busy=450/170,0/170
ring=450/1500,0/4500
congestion=450/250,0/250
callwaiting=450/300,0/10000
dialrecall=450
record=1400/500,0/15000
info=!950/330,!1400/330,!1800/330,0

Mike


#3

I use * to originate calls to the PSTN. I am using the outgoing folder to place calls. The problem: the server considers the line as answered and enters the dialplan as soon as it dials the outgoing number. So when the phone rings the message from the dialplan is already played. I read about this issue on the site (voip-info.org/tiki-index.php … o-dial+out) and the only solutions presented there were usage of callprogress=yes (but that’s ok only for us), and some delayloop in the dialplan (I don’t like that one bit). For now I have used the loop approach, but I somehow think the problem may lie in the country settings. I found the pdf myself but I couldn’t quite extract the needed info out of it to fill the conf file. I see here that you added some code to the c code. Is it working ok for you? Do you think setting these params will make * behave better on outgoing calls?

Thanks.
Mircea


#4

I did not use the outgoing folder, so I cannot speak about its issues. I read the article and I understand the problem. It sounds strange to me. I think in the terms of dial plan : calling a Dial(…) should block until the phone is answered and just then the next directives from dial plan should be called.

Regarding the parameters for country code, I am sure that those are only for “user experience”, meaning how they will hear the specific tones. I did not enter those inside the c file because I did not have the time to play with asterisk. But I’m sure it will be ok if I do it. But they will not make the outgoing calls behave better.

Mike