STUN isn't working


I have this in rtp.conf:


However when i showed stun status, it just gave me this:

It also ignored STUN message when i tried to make a call:

I’m confused because I’m not sure where the problem might be. Is it because of the STUN server, or is it from the softphones config or from Asterisk itself?

btw, I’m using STUN because I just want to eliminate NAT traversal problems, if there are any ways to optimize this please suggest me. Will setting up my own STUN server help?

What do you have on res_stun_monitor.conf file and also have you tried changing the stun server address ?


i don’t have anything in that file… is it necessary? I tried a bunch of stun server already and this one seems to work on my softphones

STUN may or may not solve your issue, which is why it is recommended for Asterisk to have the appropriate ports forwarded to it instead and for it to be configured to know it is behind NAT. What is the environment you’re running in and network layout?


I’m running asterisk on docker in public network. I use network_mode: host in docker so no firewall rules added by docker. I also don’t configure any firewall rules in host since it’s development environment. Softphones are behind NAT.

brute force attempts are the problem. set up acl and it’s better now

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.