Strange Playback problem

I have Asterisk 1.2.10 and there is very strange problem with sound files playback. I’m not newbie but have faced with such problem for the first time.
Asterisk was installed and configured by another person. The only thing I’ve done is upgrading asterisk to 1.2.10 from I thought this could solve the problem but this didn’t help.
I have 3 softphone and the can call each other without any problem.
There is simple extension in dialplan

exten => 99998,1,Answer()
exten => 99998,n,Wait(2)
exten => 99998,n,Background(beep)
exten => 99998,n,Hangup

So when I dial 9998 I should hear beep. Insted of that I see in the CLI
– Executing Answer(“SIP/909-09b05208”, “”) in new stack
– Executing Wait(“SIP/909-09b05208”, “2”) in new stack
– Executing BackGround(“SIP/909-09b05208”, “beep”) in new stack
– Playing ‘beep’ (language ‘en’)

… and silence. Call doesn’t hangup. The same is with Playback(beep) and the same is with any other file in sounds directory. There is also nothing in debug or messages files. Ive also tried to use *.ulaw files instead of *.gsm. There isn’t any problem with permissions.
Can anyone give me some advice what to do?
Thank you.

are you trying to use a codec that your new installation isn’t loading ? e.g. you have G729 modules loaded before, but they are either not loading, or you removed them from the modules directory (like a good sysadmin you are) before compiling.

I have the same problem with voicemail. my config worked perfectly under but since I upgraded to 1.2.10 ‘playback’ sounds can’t be heard.