Strange behavior after * 1.2 upgrade


#1

I have this very strange thing going on after I upgraded to Asterisk 1.2. I can make a call from outside( via a cell phone -calling myself) any direct number without a problem and I can call the reception the first time which plays a background IVR menu. Once I have called a number that plays a menu I cannot call again. I get the “no-service” message and I see on the Asterisk console that the DID that came in is totally wrong.

Any ideas what can cause it?


#2

Nobody else experienced this?


#3

Um, no, so my guess is, it has to do something with the dialplan… Maybe and old leftover wich isn’t compatible with 1.2…


#4

Well I went through the messages log file and fixed all the warnings and 1 error. The warnings were only things like ResponseTimeout and DigitTimeout that was deprecated. The error was it couldn’t load extensions.ael but Asterisk still started. But still the same problem persists.

It is funny how I can make as many calls I want and answers the calls without a problem but the moment it is doing some Playback or Background application , like even with voicemail, the next call I would get the no-service message and the DND or DID that comes in is 3000.

I have been batteling to get a server with Asterisk 1.2.0 up and running for 3 weeks now. I have 2 identical servers hardware wise. Our current production server runs Red Hat 4 EL SMP kernel 2.6.9 with Asterisk 1.07 which I had no problems at all with and installation was a breeze.
On the “new” server I have Fedora 3 kernel 2.6.12 and installed Asterisk 1.2.0. I first tried Fedora core 4 but it would not recognize the TDM400 and TE110P card. Then I installed Fedora core 3 from the ISO’s which has kernel 2.6.9 but I could not get Asterisk 1.2.0 to compile so I ran the update2date and ended up with kernel 2.6.12. Then it compiled and I can start Asterisk but with the above stated problem. I did not do a make sample as I jsut copied my etc/asterisk directory with the conf files and all the sound files.

I am not sure if I missed soemthing - it will be nice if soemone knows of a document that describes what one needs to do when you upgrade Asterisk.


#5

I’d like to suggest trying with a ‘clean’ /etc/asterisk/* dir. Just move all your config files away, and do a make samples. Then try a basic setup (as simple as possible), and see if the problem remains or not. That way you can be sure your dialplan is okay (or not).

Only thing I can find is: voip-info.org/wiki/index.php … .0+upgrade


#6

I tried with the Sample files and the demo and get the same behavior. The moment Playback, Background or Voicemail has run in the Dilaplan the next call I will get the “no-service” message and the DNIS is totally wrong. This one has me, I cannot think what causes it :frowning:


#7

I have just removed Asterisk 1.2 and installed 1.0.10 and it runs like a charm, no problem what so ever, I dont know what it is with 1.2 :frowning:


#8

Hm, if you want to debug some more, don’t hesitate to place the log here, at least the relevant part :smile:
I have no problem like that, on any of my boxes. (Supermicro, HP, clone, …)

cheers


#9

I finally got an answer to this. It is a bug since Asterisk 1.2 RC2.

Here is the link bugs.digium.com/view.php?id=5877.

It seems to be only if you have E&M wink as signalling. Thank … I am not going crazy!

flynwill you knew about this problem, why didnt you say soemthing here in the forum :smile: