Status: 405 Method Not allowed (1 bindings)


I am new in asterisk. After my basic installation and configuration on centos system, i tried to connect through x-lite. But its not getting connected. When check on sip show peers its showing below result.

welcome*CLI> sip show peers
Name/username Host Dyn Forcerport ACL Port Status Description
105 (Unspecified) D N A 0 Unmonitored
1 sip peers [Monitored: 0 online, 0 offline Unmonitored: 0 online, 1 offline]

Also find my configurations in sip.conf & extensions.conf below

callerid=name <105>

then in extensions.conf

exten=> 1234,1,Answer

Then i tried running ethereal in my machine running x-lite. its giving the below result.

astersik server to my machine - sip protocol - status: 405 Method not allowed (1bindings)

Please help me to solve the issue.


Method not allowed is a response to a method that is not allowed. You will need to find out what that method is. There is little point in giving us only 10% of the needed information.

You might want to note that X-Lite is a deliberately restricted product. If you are just learning, I would strongly advise using a dedicate hardware SIP phone.

Incidentally, I don’t believe there is a “quality” parameter.

“hungup” is not a valid application name (and hangup would be redundant here).

What is your reason for using nat=yes?

Playback will answer the call without the need to explicitly use Answer.

Generally for a SIP problem, enable full logging in logger.conf, and do “core set verbose 5”, “core set debug 5”, “sip set debug on” and provide the contents of /var/log/asterisk/full, after removing obvious noise and sensitive information.

Thanks for you quick response.

unchecking the “register with domain & receive calls” resolved the issue.
I also made a try from IP phone and find out that its working fine from there also.

Hope that i will need more assistance and help from you guys in coming days also.

Thank you once again for the valuable debug commands. :smiley:


That will prevent you making calls to the phone.