[SOLVED]silence while playing recording


I have what used to be a working A@H installation…but now when sbdy calls they can only hear silence as the custom recordings for the IVR are playing. CLI shows me that they are playing but there is no sound. ALso when the user gets sent to voicemail there just a busy signal. I can do an echo test just fine and here the voice prompts if I use one extension to dial into voicemail for example or try the echo test…

I tried to paste my cli output but it wont let me post it to the forum. In any case I have 2 problems:
1- No sound while playing the custom recording, which played before
2 - When sent to voicemail it gives a busy signal

Could it possibly be sthg to do with wav files…? The thing is they played before fine but not anymore and the gsm files do play fine. Also voicemail uses wav to record. It’s the only connection I can see between the 2…

Thanks for your help

dunno about trixbox but I once had an issue where * wouldnt play GSM files… recompile/reinstall fixed it… not sure if this is the same thing…

What version of asterisk are you using. I had problems with 1.2.11 and downgraded to 1.2.10 and had no problems (I had issues playing other files). Also you can test to see if its a problem with the sound file that you created by playing one of the files that comes with asterisk.
For Example :
Exten => 1234,1,Answer
Exten => 1234,2,Playback(digits/million)
Exten => 1234,3,Hangup

Everything is now solved my problem was that the g729 codec had unregistered…I found the usefull log in the FreePBX Tools sections and saw all the debug messages…pretty helpful.

What is Free PBX Tools section? Where? What tool?