[Solved] IP Calls forwarded, no audio. All other calls ok


I’ve recently run into a problem which has left me scratching my head for hours on end.

I’m running Asterisk with Elastix GUI. I’m using a SIP trunk with VoIP.ms, and have four POTS lines attached to the bright orange hardware (elastixdepot.com/). The four POTS lines were not used during this issue.

Problem: Silence when the called party picks up the phone on incoming calls. The callee can not hear the caller, and the caller can not hear the callee.

Description of problem:
[li]Caller dials xxx@cepm.biz.)
[/li][li]Call is routed through our PBX server, and forwarded to a POTS number (out the VoIP.ms trunk.)
[/li][li]Caller and Callee both hear ringing.
[/li][li]Callee picks up phone.
[/li][li]Both Caller and Callee hear silence, and more silence. Eventually they hang up.[/li][/ul]

Criteria for problem to occur: Only calls via sip:xxx@cepm.biz (our domain) which are forwarded to another number exhibit this silence problem.

Calls that work fine:[ul]
[li]Outbound to POTS via VoIP.ms trunk
[/li][li]Inbound via POTS (takes 2 rings to answer)
[/li][li]Inbound via POTS (takes 2 rings to answer) forwarded via VoIP.ms
[/li][li]Inbound via VoIP.ms trunk (instant answer)
[/li][li]Inbound via VoIP.ms trunk (instant answer) forwarded via VoIP.ms
[/li][li]Inbound via sip:xxxx@cepm.biz (instant answer) non-forwarded only.[/li][/ul]

Here’s my SIP debug log. I can see the RTP packets, but there seems to be suspiciously few of them for 5 seconds.

If anyone can take a quick look at the sip debug log and tell me where to look next, I’d really appreciate it!

Thank you ahead of time. :smile:

P.S. The number I called FROM was 3867756, the number dialed (owned by VoIP.ms) was 5935489. My external IP is, and the internal IP for the box is That might help when scanning through the log.

Now solved! I had enabled ‘gsm’ in VoIP.MS’s settings. Once i disabled that, audio flowed smoothly once again.

Hopefully if someone else runs across the same thing and searches for it they will find this resolution.