[SOLVED] Installing Asterisk Addons


I’m installing Asterisk Addons 1.4.7 on Asterisk I have installed previously MySQL .
When I do make menuselect, in the options about MySQL, thereis XXX written and I can not choose to install those options. I have read that XXX means that there are some dependecies problems, but I have installed MySQL and it works perfectly.
Any Idea???

Thank you very much in advance.

Install the mysql client libraries and the related development files.


Marco Bruni

I have installed mysql-server and mysql-client using RPM.
Is that enough?

You should install the development package also, in the distro I use, opensuse, is libmysqlclient-devel.


Marco Bruni

Ok, I will try.

Thank you very much

Finally you were right!!

Now I can choose the option of the mysql module. But my current problem is different, now I can not compile doing make the addons, there lot of errors compiling the h323 and the mysql module.

I had problems compiling 1.6.x and MySQL 3.23-?? Upgraded to MySQL 5.x Solved problem.

Usually, these problems are caused by incorrect header files, or header files from previous versions of Asterisk. Try deleting the old header files

and rebuilding asterisk + addons

What are the errors you are getting ??


I finally solved. I really don’t know why exactly. But the problem was that I was doing the ./configure using a de parameter --prefix==/usr/local/share/asterisk, both asterisk and asterisk addons (using the same for both of them), and maybe doing that, the asterisk addons didn’t find the location of some header or some files. I don’t know.
So, I have solved just doing ./configure without --prefix and it works.
I don’t know if I can help someone.

Thank you very much all of you for your help and answers!!!