[SOLVED] Codecs.conf entries seem to be ignored (Asterisk 13.22)

I am unable to set any custom configuration options for the opus codec in codecs.conf. I have tried much experimentation using the example codecs.conf files without success and even with an absolute minimum configuration I always receive the following warning when sip is reloaded:

[2018-08-24 21:46:29] WARNING[22459]: format_cap.c:404 ast_format_cap_update_by_allow_disallow: Cannot allow unknown format 'myopus’
[2018-08-24 21:46:29] WARNING[22459]: chan_sip.c:31647 build_peer: Codec configuration errors found in line 72 : allow = myopus

The opus codec is installed and operating properly and I do not see any warnings in the console log concerning codec creation upon Asterisk startup (other than the warnings above when the sip module is finally loaded.)

What am I doing wrong?

Content of codecs.conf:

[myopus]
type=opus
max_bandwidth=wide

changes/additions/removals to codecs.conf can’t be reloaded, they require a restart of Asterisk.
I have codec_opus.so installed, and I’m running Asterisk 15 out of branch, and I added the same thing you have to my codecs.conf, and I don’t see that warning. Just:

[Aug 27 08:49:42]   == Created cached format with name 'myopus'

Thanks for the response. Unfortunately in my case restarting Asterisk has no effect on the issue, I think the difference in our cases is related to a difference between Asterisk 13 and 15.

Can anyone running Asterisk 13 (13.22 in my case) confirm that their codecs.conf entries are being implemented?

I found the problem, I had compiled opus from the opus website distribution which worked when building Asterisk but resulted in the glitch above. If you meet the dependencies specified in menuselct (xmlstarlet, bash, and res_format_attr_opus) then Asterisk will download and install the Asterisk-specific opus build which supports codecs.conf. All you really need to do is install xmlstarlet since the other packages will already be present.

Hope this helps someone.