[SOLVED]chan_misdn and asterisk compiling problem (


I have a problem that can’t resolve my self.
I had Asterisk 1.4.9 installed (from source) and it work OK for FWD (IAX2) and SIP.

[AMD x86_64, Madriva 2007, kernel]

Then I wanted to add my ISDN BRI card and troubles begen.

When compiling from source 1.4.9 with mISDN and mISDNuser instaled (cvs), it didn’t install chan_misdn.

I did run ./configure and make menuselect (or what ever brings menu for compiling options for asterisk).

So, I downloaded version and did whole process from begining:

  • mISDN and mISDNuser installed (did get some wornings, but it finished OK).
  • mISDN scan /config /start - all went well
  • run ./configure and almost all was OK except one thing which I don’t know if it error or possible error:(this is part of ./configure output)
    [color=darkblue]checking for lt_dlinit in -lltdl… no
    checking for crashHandler in -lkdecore… no
    checking for mISDN_open in -lmISDN… yes
    checking mISDNuser/mISDNlib.h usability… yes
    checking mISDNuser/mISDNlib.h presence… yes
    checking for mISDNuser/mISDNlib.h… yes
    checking for init_manager in -lisdnnet… yes
    checking mISDNuser/isdn_net.h usability… yes
    checking mISDNuser/isdn_net.h presence… yes
    checking for mISDNuser/isdn_net.h… yes
    checking for encodeFac in -lsuppserv… yes
    checking mISDNuser/suppserv.h usability… yes
    checking mISDNuser/suppserv.h presence… yes
    checking for mISDNuser/suppserv.h… yes
    checking linux/mISDNdsp.h usability… no
    checking linux/mISDNdsp.h presence… no
    checking for linux/mISDNdsp.h… no
    checking for nbs_connect in -lnbs… no
    checking for initscr in -lncurses… yes[/color]

Don’t know if this part with mISDNdsp is reason, BUT, when I run make I get following:
[color=blue] [CC] recno/rec_utils.c -> recno/rec_utils.o
[AR] hash/hash.o hash/hash_bigkey.o hash/hash_buf.o hash/hash_func.o hash/hash_log2.o hash/hash_page.o hash/ndbm.o btree/bt_close.o btree/bt_conv.o btree/bt_debug.o btree/bt_delete.o btree/bt_get.o btree/bt_open.o btree/bt_overflow.o btree/bt_page.o btree/bt_put.o btree/bt_search.o btree/bt_seq.o btree/bt_split.o btree/bt_utils.o db/db.o mpool/mpool.o recno/rec_close.o recno/rec_delete.o recno/rec_get.o recno/rec_open.o recno/rec_put.o recno/rec_search.o recno/rec_seq.o recno/rec_utils.o -> libdb1.a
[LD] abstract_jb.o acl.o aescrypt.o aeskey.o aestab.o alaw.o app.o ast_expr2.o ast_expr2f.o asterisk.o astmm.o autoservice.o callerid.o cdr.o channel.o chanvars.o cli.o config.o cryptostub.o db.o devicestate.o dial.o dns.o dnsmgr.o dsp.o enum.o file.o fixedjitterbuf.o frame.o fskmodem.o http.o image.o indications.o io.o jitterbuf.o loader.o logger.o manager.o md5.o netsock.o pbx.o plc.o privacy.o rtp.o say.o sched.o sha1.o slinfactory.o srv.o stdtime/localtime.o strcompat.o tdd.o term.o threadstorage.o translate.o udptl.o ulaw.o utils.o editline/libedit.a db1-ast/libdb1.a …/apps/modules.link …/cdr/modules.link …/channels/modules.link …/codecs/modules.link …/formats/modules.link …/funcs/modules.link …/pbx/modules.link …/res/modules.link -> asterisk
…/channels/misdn/isdn_lib.o: In function stack_init': misdn/isdn_lib.c:1301: undefined reference tomISDN_register_layer’
…/channels/misdn/isdn_lib.o: In function setup_bc': misdn/isdn_lib.c:1088: undefined reference tomISDN_get_setstack_ind’
collect2: ld returned 1 exit status
make[1]: *** [asterisk] Error 1
make: *** [main] Error 2[/color]

Why, oh why…

Thanks for all the help!!

I can tell you Asterisk works with misdn 1.1.5 (so stable version, not the cvs), I tried just few days ago.


Marco Bruni


I’m really puzzled with all this Asterisk/zaptel/mISDN thing…

I’ve managed to install 1.4.9 Asterisk with csv mISDN.

If I try to install 1.1.5 mISDN, I get some kind of freak error (on mISDNuser), while cvs compiles great.

On the other hand Asterisk 1.4.9 installs great but it has some glitch with mISDN newer version (with XML config file) that “crashes” Asterisk if misdn-init.conf is missing.

And of course doesn’t want to compile.

To make it even worse, 1.4.9 does compile with mISDN, BUT I get following:
[color=darkblue]> misdn show channels
Chan List: (nil)[/color]

[color=darkblue]> misdn show stacks

It has become really frustrating.

Ok, so I solved issue in regard to compiling
How? Don’t ask me - I installed a whole buch of stuff to get it working - but I think that it was gtk+2.0 (devel).
Funny, it did not show it as missing as I did have gtk+2.0 installed, but I didn’t have -devel (source) for it.

But the problem remains… And for this I will open new topic.