[SOLVED] Can't make asterisk 1.8 to run on VM with CentOS 6

Hello guys,

I’ve installed many Asterisk (1.2, 1.4, 1.6 and 1.8) servers on real machines running CentOS 5.4.
Now, it’s my first try to install Asterisk on a VM running CentOS 6.3

  • When I run service asterisk start there is no output and asterisk doesn’t start.
  • When I try to run it manually with /usr/sbin/safe_asterisk, the output is as follows:
  • Then I saw that this can be fixed if I comment the row for TTY in safe_asterisk. After doing that, the output of safe_asterisk is:

I’m stuck here and I don’t know what else to try. I don’t have asterisk log file neither as it doesn’t start at all.

Processor info:

When I run asterisk’s ./configure it ends with:

You can find the configure.log here http://www.sendspace.com/file/lqx52c.
(Click “Click here to start download from sendspace”)

Your help will be much appreciated. Thanks!

Other people have reported problems with illegal instructions when using VMs. I’m not sure it was here or on the issue tracker, but searching for illegal instruction and virtual machine ought to find something.

I assume the VM in question doesnt have any consoles at all.

I’m still not convinced that it is sensible to run real time software on virtual machines.

Thanks for pointing me the direction for the search! I knew there was something wrong with the processor or similar, but this time I found a solution posted in the asterisk issue tracker. Seems that a workaround is to remove the flag BUILD_NATIVE when calling make menuselect. After recompiling it’s running ok, the only tiny thing that left is that when I call “service asterisk start” it doesn’t show “ok” but it starts it. If I call “service asterisk stop” it properly shows “ok”

Where did you remove the flag BUILD_NATIVE?
EDIT: Found it, but it didn’t work.