[SOLVED] Cannot transfer outgoing calls - only incoming


#1

Hi

I have a problem with asterisk: I am not able to transfer outgoing calls from an extension to another.

Sorry, may be this problem was already solved, but I tried to find a solution in old posts and I was not able to find it.

If I receive a call from a landline or cellular number to one of my SIP numbers, all is correct: the extensions ring and I can get the call. I am also able to transfer it using the # key specifying the extension number.

When I make a call to a landline or cellular phone I can speak but I using one of my extensions using the SIP accounts, I cannot transfer the call to another extension. Also if I press the # key nothing happen.

Please note that if I call an extension, instead of an outside number, I am able to transfer the call to another one extension.

So I image that the dial command works correctly (I defined tTr options).

I also redefined the transer keys in the features.conf but nothing changed: the call transfer works only in the described ways.

I update asterisk from the 1.2.2 to the 1.2.3 and 1.2.4 version but nothing changed, in both 1.2.3 and 1.2.4.

Waiting for an ordered Digium board, I use 2 UTStarcom ATA’s for connect the extension to my asterisk server. As the call transfer from/to extensions only works correctly, I suppose that ATA’s are not responsible for this transfer problem.

Any ideas?

Thank you in Advance


#2

are you using Asterisk@Home ?


#3

Yes I installed Asteriskathome 2.3 and manually updated asterisk from the www.asterisk.org site.


#4

so you’ve added the T option to DIAL_OPTIONS on the ‘General’ page right ? it won’t work for outbound calls, you actually need to modify the dialstrings in [macro-dial], adding “,T” to each one that is used for outgoing calls.

and i would recommend removing the T from the options, all it does is allow incoming callers to transfer calls :smiley:


#5

Thank you for your help!

I added the ,T non for each trunk but directly in the doal-out-trunk in the extensions.conf.

Everything now work. and I removed the T in the general options :smile:

Thank you again