[SOLVED] Callback not possible with country code AND leading

Hello Guys,
I am from germany so my english is not the best… :smile:
We have some trouble with the callerid when calling to cellphones from our local mobile provider (O²).

The Asteriskserver is version 1.2, outgoing calls are isdn, interns are SIP and we use Snomphones.
If we call someone outside, doesnt matter if mobile or landline, we give the callerid 0. This works all the time perfect but when we call someone with an O² mobile phone he gets +490. To work it have to be +49 OR 0.

Best regards

Is this bad described?
Do you need more infos?
Had anybody this problem before?

I have no experience with ISDN on Asterisk/Zaptel. However, ISDN normally expects numbers in national or international plan format, i.e. without the 0 or 00, and you have to identify the format being used. Either the landline network is tolerating the use of an initial zero in national number format, or the mobile network is not prepared to accept the actual dialled number format.

You need to provide your zaptel configuration, at least the Asterisk side, and maybe also the driver, to be able to see what you have done, but you probably want to specify national number format, and then supply the number with no leading 0.

Hello David,
thanks for your answer.
I think there is a miss understanding with the numbers. When I say 0 I mean 0 this is the standard format to call inside Germany (national), the leading zero is needed to get a dial tone here. So the caller id we give is correct.
The international format would be +. But we cant give the international format as regular caller id because the landline provider blocks all +49 and 0049 numbers.

We have no zaptel.conf but a misdn.conf: pastebin.com/VkNi3bAB

That is not the standard ISDN format. The standard ISDN format is something like:

Type of number = national
Number = …

There is an option to specify that the type of number is as dialled, but the local/national/international types are more likely to work.

Sry for the delay, had much work the last weeks.

Did you mean to change the “dialplan” value in misdn.conf from 0 (unknown) to 2 (national)?
It’s at line 227-248.

I believe so, but you will also need to strip the leading zeroes as that selects national number format, but is not part of the national number.

Hi and sorry for grave digging but I have to say thank you very much. And other people with the same prob can resolve it too. I hate googleling forum posts without an answer :smile:

It work after I changed the “dialplan=2” (national) in misdn.conf and the callerid in the outbound context is (without a leading zero!)

Now we have the physikal Asterisk not anymore but a virtual machine with a berofix box. The appropriate parameter there is “onumplan” which must be also national.