Sipura SPA-1001 NAT and Asterisk


#1

Greetings,

I have an asterisk box at home setup on my home POTS line which is working great. Recently I purchased a Sipura SPA-1001 box for use elsewhere, which also works great with my broadvoice account. Today, I decided to configure the SPA-1001 to receive calls from my asterisk box.

Here is where my troubles begin:

The SPA-1001 is registering with asterisk just fine. In fact I can dial it and it rings. Unfortunately, after the call is initiated, no audio is transmitted in either direction.

I am guessing this is due to the fact that both machines are setup with NAT and have private IP addresses. Both configured to route ports 5060-5063 and 10000-20000 to the correct machines.

In the SIP configuration on asterisk (in the context for the SPA-1001) I have:
nat=yes

In the configuration of the SPA-1001 I have:
NAT Mapping Enabled and NAT Keep Alive Enabled
In the advanced screen of the SPA-1001 there are options relating to VIA and STUN which I am unfamiliar with but after experimenting with them I still have the same issues.

Any advice would be greatly appreciated!


#2

That’s not enough information. You’ll have to explain your network configuration properly.

Are the sipura and the asterisk box on the same LAN? Are you trying to connect them through the internet (i.e., trying to connect the sipura to the asterisk box via the internet)? What sort of firewall(s)/NAT system(s)? Etc.


#3

Trying to connect them via the internet.

Linksys routers on both sides. No firewall, only NAT. DSL on one side, cable modem on the other side. Dynamic IP addresses with DynDNS hostnames that are kept up to date.


#4

Are you setting the “externip” parameter in sip.conf?


#5

Yes, I had externip set…

Unfortunately, after much trial and error (with one success that I couldn’t duplicate) I was forced to move my asterisk install outside the NAT and use it as a gateway/router for my network (in place of a netgear router) as well as using it as the asterisk server.

This is fine, I have more flexibilty but it reminded me why I never did this (or could get things to work correctly) in the past (issues with MTU sizes on my PPPoE based DSL, crazy ipchains commands, DHCP headaches and so forth).

In any case, my setup is complete!

ps. Next time I will go with an IAX based solution :wink: