SIP Voicemail recording not working


#1

I’m curently using Asterisk 1.2, but i had the same issue with 1.0.7

Whenever a call gets redirected to voicemail, the recording fails…
here’s a log sample: (phone number replaced wix x’s)
– Playing ‘beep’ (language ‘fr’)
– Recording the message
– x=0, open writing: /var/spool/asterisk/voicemail/default/xxxxxxxxxx/INBOX/msg0005 format: wav, 0x8150468
Nov 24 09:33:38 WARNING[23025]: app.c:653 ast_play_and_record: No audio available on SIP/xxxxxxxxxx-2257??
– User hung up
== Spawn extension (vms, xxxxxxxxxx, 6) exited non-zero on ‘SIP/xxxxxxxxxx-2257’

From what i see there it could be a codec problem, but i don’t get any SIP error concerning codec negotiation…

And before getting to voicemail, codec negotiation goes well:
Capabilities: us - 0x8000e (gsm|ulaw|alaw|h263), peer - audio=0x4 (ulaw)/video=0x0 (nothing), combined - 0x4 (ulaw)
Non-codec capabilities: us - 0x1 (telephone-event), peer - 0x1 (telephone-event), combined - 0x1 (telephone-event)

the peer is a Tekelec T7000 switch, and currently the only codec i set on it is ulaw.
I’d just like to know if recording voicemail is compatible with using only ulaw as codec…
Or if something else could create the problem: Nov 24 09:33:38 WARNING[23025]: app.c:653 ast_play_and_record: No audio available on SIP/xxxxxxxxxx-2257??

Thanks in advance


#2

Is there any NATing going on between Asterisk and the Tekelec T7000 switch?


#3

Ok, we fixed our problem…

The problem was the t7000 was doing load balancing over 2 FastEthernet port, and one of them could not ‘talk’ the to asterisk box…

Sorry for posting a stupid question ;-p