SIP registration issues

Hey everybody

I am pulling my hair out over this issue. I have registered an account with icall and have been using their service nicely for some time.
However I am having an issue registering (it’s me, not them, I talked to them for over an hour trying to figure it out). I can successfully register to one of their servers (they’re moving to another one) but I can’t register to their new server. However, if I used IDEFISK and enter all the new server information it will successfully register and work flawless. So therefor it is an asterisk or server issue.
I don’t know where to look, I can ping, traceroute, nmap, nslookup, etc… from the server and that all works. I don’t know where else to look.

Any ideas would be GREATLY appreciated.

Thank-you, a very frustrated

ok, some updates.
I have tried different version of asterisk, 1.4.10, and 1.4.19, both from the same machine and same problem. also I have tried 1.2.13 on a different server, and it has the same issues.

more info.
If I restart my router or flush the state table asterisk will successfully register with their server, but after a few minutes it will timeout again until I flush the table again. It seems like a router issue, but asterisk has no problems registering with other servers, just the one.

Hi Did you ever sort out this problem cause I am getting exactly the same issue. If I use another brand of router it works fine. can’t figure out what the settings need to be.