Please help me, sip registration timeout


#1

Hi all,

I hope you guys can help me urgently on this. No matter how much I try I just couldn’t get asterisk to register itself as a SIP client to one of my voip provider at all. It always says this

chan_sip.c:5627 sip_reg_timeout: --Registration for ‘xxxxxx’ timed out, trying again (attempt #1)

I searched the net and forum but to no avail… please help me.

here is part of my sip.conf file

[general]
port = 5060
bindaddr = 0.0.0.0
context = default
disallow=all
allow=ulaw
allow=alaw
allow=g723.1
allow=g711
allow=g729
dtmfmode=auto

register => 433333:123345@123.234.12.23

[voip-provider]
type=friend
secret=123345
username=433333
host=123.234.12.23
fromuser=433333
context=voip-ps

During my searches for an answer regarding this question, i saw a few people were having this kind of problems, but most of the time, their questions could never be answered. I hope you guys can help me with this please. This is actually a very urgent matter for me. Thanks a lot guys.

-sd


#2

Looks like a network problem. Can you ping your provider? Can you register with another provider (IE: FWD)?


#3

Hi zmanea,

I tried with as many voip providers as I could and the results are the same, timed out. I tried fwd, i followed exactly to what other people have done but still, unable to register. One thing that i see is that when i tried to sniff the traffic to see what’s going on with my asterisk, I see my asterisk attempts to send many requests and not receive anything back at all from the providers. It keeps sending and sending…

I hope you can help me with this. I’m running out of time. Thanks guys


#4

It seems the unit is behind the firewall and the reply messages are blocked. Please check your firewall and ensure the ports is ready. In the case, there should be some messages received even if the call is established or not. Please update.


#5

Hi fung27 and all,

I’ve managed to get it work. Thanks so much fung27 and everyone. It turns out that the setup of my company’s network prevents asterisk from registering itself. I tried to change settings of our firewall to allow sip and asterisk still didn’t work, and then I had to dig deeper only to find out my gateway also has its own rules that prevent sip traffic and et al.

I just setup a gateway for my own use and asterisk works like a champ now. Asterisk is fun but it can be daunting sometimes :smile:. I love it nonetheless. Next is to do some more reading on how to make asterisk calculate the calling time, cdr and all that. It should be fun.

Take care yourself guys and I’ll definitely come back here to offer help and ask for help as well :wink:.

-sd