Sip port 5060 routing problems


#1

Hi all,

I have a weird problem that no-one up to now has been able to answer, can any of you help.

Problem:
Looking in the logs - SIP Peers says:
sipgate.co.uk:5060 USERNAME 120 Request Sent

I am not able to connect - using IAX this works.

I think the problem is something to do with my firewall, looking in the logs I see that all my outbound routing is working no problems the data is being sent.

When sipgate send data to me I see the source port is 5060 but the destination port is 0. but it wants to send it to the correct IP address.

Does anyone have any ideas or suggestions? I am using Kerio Winroute firewall as the router and firewall.

Any ideas or suggestions would be welcomed - If needed I can provide further information about our config.

Thanks
Ben


#2

Sipgate don’t support iax - so how can it work with iax?

Have you read their help pages on asterisk and on firewalls?

sipgate.co.uk/faq/index.php? … k=688#num2

and

sipgate.co.uk/faq/index.php? … k=100#num4


#3

Sorry - I have just re-read the post and I did not make clear what I had put. My Voip providers that I am connecting to with IAX work, it is only the telcos I connect to with SIP that fail. (I think that makes more sense!)

Ben


#4

Yes, it makes sense now.

IAX2 doesn’t have the same problems with NAT that SIP has. You will need to make sure your firewall configuration is right.

I guess you’re using windows for that, so i can’t comment on what your chances are of getting it to work as i don’t know (and don’t want to know) anything about windows. However, all things windows seem to be pretty bodgy to me, so you might have a shitfight on your hands!

First, though, you need to read the instructions on the Sipgate web site, which i mentioned before, and follow them. If it still doesn’t work, post a full account here of what you’ve tried and what the results were and hopefully someone will be able to help.