Silence until agent answers

Interesting issue I have never run into before with Asterisk.

Using Asterisk 1.8.x (please don’t tell me to upgrade, it’s not possible at this time).

When someone dial direct into the system to any of the numbers, we Answer, then push them to a queue and either play MOH on Ring sound.

This has always worked fine and still does. Most people forward calls to our numbers from their business line/phone system.

For this one customer and only one customer, there is complete silence for the caller once their phone system initiates the forward to our number. Our Asterisk box answers the call, we have even tried playing sounds using Playback etc but nothing, complete silence until one of the agents answers from the queue.

Really bizarre. canreinvite=no is set so, there shouldn’t be any issues with Asterisk getting optimized out.

Any ideas a really appreciated. I know it’s on their end but, it would be great to find a way to make Asterisk, make the customer’s phone system behave correctly LOL.

Sounds like it’s not finding the file to play. Can you post the logging for a call to that queue and the queue config?