Set Outgoing MSN

Hi,

I’m using asterisk 1.2.13 (from source) on a Intel Celeron 333 pc.

It has analog card from digium installed and a hfc isdn card.

the “problem” is on the isdn card. It has 3 incoming numbers: 1 = business; 2 = fax; 3 = private. When i make a business call out everything is fine… The callee sees my business number on screen. But when i make a call with one of the private phones (they all have different sip account’s so it is easy to distinguish them) the callee still sees the business number, and it should show the private number… I’m setting the caller id in sip.conf as it is said in the asterisk wiki. But is doesn’t seem to work… Can anyone help?

Thanks.