Sending empty rtp packets

I run a voicemail service, and I’m running into a situation where the line disconnects after five minutes of leaving a voicemail. It’s not that the voicemail application allow them to leave a longer message, the line just goes dead. This problem happens with my local DID numbers, but not my toll-free numbers and appears to be carrier-related.

The Asterisk CLI indicates the cause of the disconnection is that the user hung up. I’ve tried adding these settings to SIP_Custom.conf, but that hasn’t cured the issue.


In conversations with Vitelity where I describe what’s going on and that the settings above aren’t working but should, they have said, “We have clients that do exactly what you are doing - They have custom scripts that send out blank/silent rtp packets out every x amount of seconds. Unfortunately I’m not quite sure how it’s done myself or I would definately provide you with the info… i’m sure you could find something if you dig around”.

So, how do you keep the line alive? Because it’s voicemail I can’t play beeps or a recorded message, and the rtp settings aren’t working for me. Thanks.

Could you please post your asterisk console messages.


This was fixed in 1.2

transmit_silence_during_record = yes

to the top of your asterisk.conf


That did the trick.

I can do some testing, but do you know if technically if that setting replaces the rtpkeepalive setting in SIP.conf? Are they meant to do the same thing?



Im not sure. You will have to look at the source, but this is the setting that I use, as it works for SIP and IAX

If you go back in Bugzilla you will find the birth of this fix