Voicemail RTP Issue

Hello everyone,

PBX A and PBX B, both are in the same DataCenter, dedicated LAN and WAN IPs, each PBX has a SIP Trunk (same carrier) no Trunks between the PBXs. Both PBXs user Asterisk 16.6.2

When any extension of PBX A calls the main number of PBX B, there’s RTP both ways just fine, they can dial extensions, speak with users, no DTMF issues etc. and vice versa.

The only time we have an issue, is when a user of PBX A reaches a Voicemail on PBX B, PBX B stops sending RTP to the carrier after the beep which obviously results in the call greeting disconnected after 30 seconds.

Is there any setting that we might have missed?

Again, to confirm, when anyone is calling the PBX from their cellphone and leaves a voicemail there’s no issues then.


There is an explicit option required to send silence when recording[1].

[1] https://github.com/asterisk/asterisk/blob/master/configs/samples/asterisk.conf.sample#L60

Thank you Joshua for replying.

Can you please elaborate a little more?

I added transmit_silence = yes but as its mentioned there it needs to be transcoded. So I added transcode_via_sln = yes as well.
But it still doesn’t work.

I will be honest, I don’t completely understand when it needs to happen.

Appreciate your time.

Only the “transmit_silence” option is needed to be configured. There also needs to be a timing module loaded which can be tested using the “timing test” CLI command. Did you restart Asterisk to have it take effect?

I tried before posting to use the transmit_silence = yes, but it didn’t work so I added the trancode line as well and it didn’t work either, sorry I failed to mention that.

pbx*CLI> timing test
Attempting to test a timer with 50 ticks per second.
Using the 'timerfd' timing module for this test.
It has been 1000 milliseconds, and we got 50 timer ticks

It still hangs up after 30 seconds. What am I missing?

Thank you

What is the console output, along with “rtp set debug on”?

See pastebin link: https://pastebin.com/KCjRktNC this is how many lines putty displayed once the call ended.
Let me know if you want me to try to grab from earlier in the call as well.

The beep is at line 488, the PBX starts recording at line 531 and stops sending audio.

Thank you

Does “core show settings” confirm that transmit_silence is set?

That was the issue. I forgot you have to restart asterisk for these settings to go in effect. It is working now.

Thank you so much!

Follow up question:
Whats the difference between transmit_silence and transmit_silence_during_record ?

There is no difference, they are the same. If I recall correctly the option was expanded to cover sending silence during more scenarios so it became transmit_silence.

Got you.

Thanks again for your help! Stay safe and healthy.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.