Second Network Card - Newbie

Hi knowledgable people,

I am trying to add a second network card into an AsteriskNow installation.I have now tried several cards…eventually buying two of the same. They all are recognised and drivers are installed, but no matter what I do the second card will not pick up an IP address. The reason i want a second network card is so i can give it another IP and secure the device behind a firewall on a different IP. I have tried giving the card static ips but the second cards never accept any incomming connection from the lan either…?

What am i doing wrong i have been struggling with this for months now… it seems a pathetic hurdle to get stuck on… (i had previsouly setup a different box with one card and it worked perfectly well, but now i want to secure it i’m stuck…)

Thank you all in advance for any help you can offer.


what have you got in

/etc/sysconfig/network-scripts ?



I have a load of files or folders in there IFCFG-eth0, ifcfg-eth1 ifcfg-eth2 ifcfg-lo infact possibly too many enterin here… but i have just read somehwere that only eth0 is enabled by default the other card needs to be manually enabled… not sure how though…

Thanks in advance for all your help

Ok the file you need to look at is ifcfg-eth1 and set it up properly.

TO be honest , Google is your friend here, there are loads of tutorials on it covering setting up the network.


Thanks Ian, i tried typing ifcfg-eth1 but it said command not found ? and didn’t open the file so not sure what command i should be using really. Thank you for your help…I will venture forth toward google now.

slowly i will make progress :smile:

Thanks again





Hi Ian,

Thanks for the direction, but i am unable to buy that for a couple of weeks. I have got a working Asterisk box and have managed that config fine… i’m just struggling what i thought wold be a straight foward command… or a way to open this file using an editor of some description.

I really want to get this nic up and running ASAP i have found on the internet “Note that eth0 alone is enabled by default. Other interfaces must be enabled manually(Edit /etc/sysconfig/network-interfaces/ifcfg-ethx and set ONBOOT=yes).”

Would it be possible for someone to kindly post the command i need to edit this second nic appropriately.

It would be much appreciated…


For ASAP request use google.

You now has the answer, you need to edit your ifcfg-ethx file, or in RH based distro use: system-config-network-tui from console, select your card save and restart the network with service network restart and you done it.

Thanks Navaismo,

I appreciate your help and have been using google… but all everyone says is “edit your ifcfg-ethx file”

but HOW? do i need to use putty, i’m currently trying from the console… I have navigated to the /sysconfig/network-scripts folder and i have tried

edit ifcfg-eth1,

open ifcfg-eth1…

this is where i’m getting stuck, i don’t know the HOW bit… looked through centos Wiki, gone onto variousl linux forums… just need the HOw PLEEEEEEEEEEEEEeeeeeeeeeeeease… i’m sure this is basic stuff but as a newbie i don’t know the answer.

Oh I see, yes to edit manually you need a text editor. In console put this command:

nano /etc/sysconfig/network-interfaces/ifcfg-ethx, nano is the text editor. If nano isnt installed try yum install nano. Or try with:

vi /etc/sysconfig/network-interfaces/ifcfg-ethx, vi is another text editor, but nano is easier.

I recommend to you use this command if you are using CENTOS:

Then press enter and the console turn a blue screen you can navigate with the down or up keys and tab. Press enter for edit the desired device etc.

brilliant- Thank that is exactly what i’m after… appologies but being a a bit green :mrgreen:

I was able to edit the card and enter static ip’s using system-config-network but couldn’t enable it on boot…

Thanks again…