I would like to get some help for my site.
At first I’ve builded it using trixbox, but I had to change operating system because of other reasons. So I switched to Debian. My system is running now, but my website is not functioning because Asterisk is not working now.

I have a website where people who like to play original tabletop roleplaying games, can play with each other using a java sip softphone, running directly on the site.
I’ve written the necessary codes to put appropriate data into the necessary places, to make it work (into conf files, asterisk mysql database, and asterisk realtime database) when a new user is registering to the site. It was working. It took a lot of time to experiment everything, but now I’m very short of time, I don’t have weeks to experiment so I would greatly appreciate if somebody could help me out. I would really like my site to work properly.
So the point is, that I only need conferences, and I need only my java sip softphone to be registered. I don’t need anything else. I believe, I need only very simple conf files for this to achieve. So everybody who is logging in to the site, his extension (or number or I don’t know how to say it) is registered in asterisk, and they can call conference rooms where they can play.

I have installed asterisk from package. Interesting but it seemed dummy was missing (I figured it out somehow). So I installed dummy also. It still doesn’t work.
first question: do I need any mysql databases to make it work at all?
second question: I’ve installed asterisk gui. I’ve registered myself on the gui but I don’t know where the data is stored. I wanted to edit config files and so on manually to register another user but I can’t see it on the gui. but the other user seems to be working, when he logs in also, I can see on the gui that he’s online or something.
In asterisk cli I see that he is online/registered.
The problem is we can’t talk to each other in the conference room created on the gui, because the following error message:

[quote][Jan 6 20:01:52] WARNING[7746]: rtp.c:1144 ast_rtp_read: RTP Read too short
[Jan 6 20:01:52] WARNING[7746]: rtp.c:1144 ast_rtp_read: RTP Read too short
[Jan 6 20:02:26] WARNING[7746]: rtp.c:1144 ast_rtp_read: RTP Read too short…[/quote]

Now I’m here, I’m stuck. I can’t find any relevant information that could help me what to do with it. RTP ports are open from 10.000 to 20.000, 5060 is also open. trixbox was working with these firewall settings. I think I have the very same settings now in asterisk, but it’s not working.

So all in all, I would like to make it work again. I would like to know where user and conference data are stored, so where to put these data with my script in order to dinamically create users and conference rooms (and to make them visible in asterisk gui if possible). I need also CDR to have data when and how long users used the system, but the first step is to make it work in basic. I would greatly appreciate any help. I hope somebody is here who also likes roleplaying games and the idea to play them online through a simple working website. Thanks in advance!

I don’t know if this error message has anything to do with the problem that we can’t hear each other in the conference, because I have found informations that it’s not really a problem. others also had this but could hear each other. but then, why we can’t hear each other?
I’ll try to register another user on the gui and we try if we can hear each other like this. If yes, the problem is with my custom code running while user registration. If not, I’ll try another sip softphone, if still not, there is something not okay with my asterisk settings.

when I connect to asterisk with the softphone, it says:

is this port number good? my rtp ports are open from 10.000 to 20.000. Isn’t it a problem?

interesting, but now I see the new specially inserted (with my custom code) user in the gui. maybe it’s just taking a little time.

REGISTER only addresses SIP port numbers.