Ringing issue

I have an issue where the caller is not hearing any ringing. The scenario I have is

Inbound SIP -> Asterisk -> DeadAGI -> ATA

Essentially when an inbound SIP call is received by Asterisk, it is passed to A2Billing using DeadAGI. That application then in turns dials the appropriate ATA. The dial string used by the application is:


diddestination is a section in my extension.conf, as such:

exten => _X.,1,Set(DEST=${EXTEN})
exten => _X.,n,Goto(s, 1)
exten => s,1,Ringing
exten => s,n,Dial(SIP/${DEST},20)
exten => s,n,Goto(s-${DIALSTATUS},1)
exten => s-ANSWER,1,Hangup
exten => s-CONGESTION,1,VoiceMail(${DEST})
exten => s-BUSY,1,VoiceMail(${DEST})
exten => s-NOANSWER,1,VoiceMail(${DEST})
exten => s-CHANUNAVAIL,1,VoiceMail(${DEST})
exten => s-CANCEL,1,VoiceMail(${DEST})

Everything works except the calling party does not hear any ringing. My assumption is that the ATA on the other end isn’t generating a ring tone therefore it’s Asterisk’s responsibility to do that.

I’ve tried adding the r option to the dial command inside the diddestinations “wrapper” as well as the dial command used by the A2Billing application (shown above). Neither works.

Any assistance would be greatly appreciated.


You need at last “sip set history on” output.

There is no way for a SIP user agent to reject a 180 Ringing and force the other end to treat it as though it had sent 183 Progress.

You could try using the Progress application, but I don’t think that is the real problem, as no SIP phone should fail to honour a Ringing response.

Hi David. Sorry for the delay in my response.

Here is the output of sip show history on my inbound channel from my DID provider:

  1. Rx INVITE / 1 INVITE / sip:1403XXXXXX@XX.XX.XX.175
  2. NewChan Channel SIP/5060-083fcc18 - from 58809857-3476230807-760023@msw
  3. TxResp SIP/2.0 / 1 INVITE - 100 Trying
  4. TxRespRel SIP/2.0 / 1 INVITE - 200 OK
  5. Rx ACK / 1 ACK / sip:1403XXXXXX@XX.XX.XX.175

Here is the output for the outbound channel to the ATA:

  1. NewChan Channel SIP/9296706990-b73005c0 - from 529d5a652e67548c6ae8964b
  2. TxReqRel INVITE / 102 INVITE - -UNKNOWN-
  3. Rx SIP/2.0 / 102 INVITE / 100 Trying
  4. Rx SIP/2.0 / 102 INVITE / 180 Ringing

I see the ringing event but I don’t hear anything on the line.

Should I see a re-transmit of the 180 on the inbound channel back to the PSTN?

Any help is greatly appreciated.

Have you answered before dialling the local channel?

That worked. That completely slipped my mind.

Much appreciated!

I was more concerned that you might have answered and therefore there would be no 180 Ringing. If you have to answer before the caller hears ringing, it looks like a bug, however I’ve never seen Asterisk misbehave in this way. Which version are you using?