Ring back not working


#1

Hello everyone! I have asterisk installed and it has been working fairly well however I now have an issue with ring back and wanted to know if anyone had a suggestion on my issue.

When someone dials our number which is coming in from broadvoice they do not hear a ringback tone they hear silence until we answer the phone thats it.

I would like to know how to fix this so they hear a ring back tone until we answer the phone. If I dial from one extension to the other I do hear the ring back tone. If we dial out we also hear the ring back tone.


#2

An ‘r’ in the ‘Dial’ options for the called phone in extensions.conf should do the trick.

See: voip-info.org/wiki-Asterisk+cmd+Dial


#3

I’m new and not sure were to go… Could you give me some sort of a sample and or context location.

Thanks…

Will


#4

In extensions.conf:

exten => 3,1,Dial(SIP/swaggie,30,r)

note the “r” option at the end of the Dial command parameters.