Inbound caller does not hear the Ring


#1

Using Asterisk@home. I looked all through the posts and can’t find any answers.

Inbound calling works. I hear it ring on my side but the caller has dead air till I either pick up or VM picks up.

For kicks I wrote down all my settings for the trunks outbound and Extensions. Reloaded Asterisk@home 1.5 and reset every thing back up. Still no ring.

Using Broadvoice.

Ideas?


#2

This is a problem with asterisk@home 1.5. Try using 1.3 Also, in your extensions.conf file, edit macro-dial. So it looks something like this…

exten => s,1,GotoIf($[ “${MACRO_CONTEXT}” = “macro-rg-group” ]?4:2) ; if this is from rg-group, don’t strip prefix
exten => s,2,GotoIf($[${CALLERIDNAME:0:${LEN(${RGPREFIX})}} != ${RGPREFIX}]?4:3) ; check for ring-group prefix
exten => s,3,SetCIDName(${CALLERIDNAME:${LEN(${RGPREFIX})}}) ; strip off prefix
exten => s,4,Playtones(ring)
exten => s,5,AGI,dialparties.agi
exten => s,6,NoOp(Returned from dialparties with no extensions to call)
exten => s,7,SetVar(DIALSTATUS=BUSY)
exten => s,10,Dial(${ds}) ; dialparties will set the priority to 10 if $ds is not null

; Ring an extension, if the extension is busy or there is no answer send it
; to voicemail
; ARGS: $VMBOX, $EXT

in other words, add the line exten => s,4,Playtones(ring), or you could add that line at the top. ie.

exten => s,1,Playtones(ring) … but you must comment out ;exten => s,1,GotoIf($[ “${MACRO_CONTEXT}” = “macro-rg-group” ]?4:2). It makes no difference.

Anyway, what this does, callers will get a ring tone generated by asterisk itself, as defined by indications.conf. All callers will get this ring tone. Usually what happens the ringing tone comes from the SIP phone itself, or the FXE/FXO module. Doing it this way, when you call another extension from any device connected either as an extension to your A@H system, or an incomming call on a trunk, will recieve the ring tone as defined in indications.conf. This will solve the problem. As least it does on all the other version of A@H. Version 1.5 is a little iffy.

I have found it usefull using doing it this way, becuase, we have 4 asterisk mechines interconnected via the internet using ADSL , and least we get an Idea of how our connection will be like when making calls to other sites before the other party answers, by the quallity of the ring tone.


#3

I have this problem too. The calle hears no ring tone at all, but everything else works fine.

My extensions.conf

[from-pstn-reghours]
exten => s,1,GotoIf($[${FAX_RX} = disabled]?from-pstn-reghours-nofax,s,1:2) ; if fax detection is disabled, then jump to from-pstn-nofax - else continue
exten => s,2,Answer
exten => s,3,Wait(1)
exten => s,4,SetVar(intype=${INCOMING})
exten => s,5,Cut(intype=intype,-,1)
exten => s,6,GotoIf($[${intype} = EXT]?7:9) ; If INCOMING starts with EXT, then assume its an extension
exten => s,7,Wait(3) ;wait 3 more second to make sure this isn’t a fax before dialing someone
exten => s,8,Goto(ext-local,${INCOMING:4},1)
exten => s,9,GotoIf($[${intype} = GRP]?10:12) ; If INCOMING starts with GRP, then assume its a ring group
exten => s,10,Wait(3)
exten => s,11,Goto(ext-group,${INCOMING:4},1)
exten => s,12,GotoIf($[${intype} = QUE]?13:15)
exten => s,13,Wait(3)
exten => s,14,Goto(ext-queues,${INCOMING:4},1)
exten => s,15,Goto(${INCOMING},s,1) ; not EXT or GR1 - it’s an auto attendant
exten => fax,1,Goto(ext-fax,in_fax,1)
exten => h,1,Hangup